hdu4813 Hard Code

Hard Code

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 999    Accepted Submission(s): 708


Problem Description
Some strange code is sent to Da Shan High School. It's said to be the prophet's note. The note is extremely hard to understand. However, Professor Meng is so smart that he successfully found the pattern of the code. That is, the length of the code is the product of two prime numbers. He tries to reallocate the code into a grid of size N*M, where M is the bigger prime. In specific, he writes down the letters of the code to the cells one by one, from left to right, and from top to button. In this way, he found the code eventually readable.

Professor Meng wants to know all the secrets of the note right now. But he doesn't take his computer with him. Can you help him?
 

Input
The first line of the input is L (L ≤ 1000), which means the number of test cases.

For each test case, the first line contains two prime numbers, which indicates N, M (0 < N * M ≤ 1000) as describe above. The second line contains a string, i.e., the code, containing only lowercase letters. It’s guaranteed the length of the string equals to N * M.
 

Output
For each test case, output N lines, each line with M letters representing the readable code after the reallocation.
 

Sample Input
  
  
1 2 5 klmbbileay
 

Sample Output
  
  
klmbb ileay
嗯,这道题看懂题了你就会做了,翻译一下,1为测试数据组数,2为将字符串分为几部分,5为分成的每部分的长度
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char s[10010];
int main()
{
    int t,n,m,lens,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        scanf("%s",s);
        lens=strlen(s);
        for(i=0,j=0;i<lens;++i)
        {
            j++;
            printf("%c",s[i]);
            if(j==m)
            {
                printf("\n");
                j=0;
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值