HDU 1698 Just a Hook 【线段树】

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23705    Accepted Submission(s): 11865


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 


Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 


Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 


Sample Input
      
      
1 10 2 1 5 2 5 9 3
 


Sample Output
      
      
Case 1: The total value of the hook is 24.
 


题目大意就是说,开始时这些由连续的金属棍组成的钩都是由铜铸成的,然后铜的价值(大概意思)是1,银的是2,金的是3,现在要进行一系列的操作,这些操作使得那些棍转化为相应的材质,问最后钩的总价值。至于测试数据,首先是测试数据组数,之后是棍的个数,然后是操作的个数,之后就是一系列的操作,例如x y z代表从x到y 的棍材质变为z。

#include <iostream>
#include<cstdio>
#include<cstring>
#define maxn 100000+10
using namespace std;
int sum[maxn<<2];
int add[maxn<<2];
void pushup(int o)
{
    sum[o]=sum[o<<1]+sum[o<<1|1];
}
void build(int o,int l,int r)
{
    sum[o]=1;
    add[o]=0;
    if(l==r)
        return ;
    int mid=(l+r)>>1;
    build(o<<1,l,mid);
    build(o<<1|1,mid+1,r);
    pushup(o);
}
void pushdown(int o,int l)
{
    if(add[o])
    {
        add[o<<1]=add[o];
        add[o<<1|1]=add[o];
        sum[o<<1]=add[o]*(l-(l>>1));
        sum[o<<1|1]=add[o]*(l>>1);
        add[o]=0;
    }
}
void update(int o,int l,int r,int a,int b,int v)
{
    if(a<=l&&b>=r)
    {
        add[o]=v;
        sum[o]=add[o]*(r-l+1);
        return ;
    }
    pushdown(o,r-l+1);
    int mid=(l+r)>>1;
    if(b<=mid)
        update(o<<1,l,mid,a,b,v);
    else if(a>mid)
        update(o<<1|1,mid+1,r,a,b,v);
    else
    {
        update(o<<1,l,mid,a,mid,v);
        update(o<<1|1,mid+1,r,mid+1,b,v);
    }
    pushup(o);
}
int query(int o,int l,int r,int a,int b)
{
    if(a<=l&&b>=r)
        return sum[o];
    pushdown(o,r-l+1);
    int mid=(l+r)>>1;
    int ans=0;
    if(b<=mid)
        ans+=query(o<<1,l,mid,a,b);
    else if(a>mid)
        ans+=query(o<<1|1,mid+1,r,a,b);
    else
    {
        ans+=query(o<<1,l,mid,a,mid);
        ans+=query(o<<1|1,mid+1,r,mid+1,b);
    }
    return ans;
}
int main()
{
    int t,n,q,x,y,z,cnt=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&q);
        build(1,1,n);
        while(q--)
        {
            scanf("%d%d%d",&x,&y,&z);
            update(1,1,n,x,y,z);
        }
        printf("Case %d: The total value of the hook is %d.\n",++cnt,query(1,1,n,1,n));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值