HDOJ-1495-非常可乐【广搜】

非常可乐

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7991    Accepted Submission(s): 3191


Problem Description
大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。
 


Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。
 


Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。
 


Sample Input
  
  
7 4 3 4 1 3 0 0 0
 


Sample Output
  
  
NO 3
 


Author
seeyou


恩,题目大意就是说 ,广搜,六种倾倒方式都遍历一遍。看人家写的代码把倒的方式写成函数调用代码短了好多,然后并没有学会,就这样了,长就长吧


#include <iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define maxn 101
using namespace std;
struct node
{
    int a,b,c,t;
};
bool vis[maxn][maxn][maxn];
int judge(node a)
{
    if(vis[a.a][a.b][a.c])
       return 0;
    return 1;
}
void bfs(int a,int b,int c)
{
    queue<node>q;
    node ss,now,next;
    ss.a=a;
    ss.b=0;
    ss.c=0;
    ss.t=0;
    vis[a][0][0]=true;
    q.push(ss);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        if((now.a==now.b&&now.c==0)||(now.a==now.c&&now.b==0)||(now.b==now.c&&now.a==0))
        {
            printf("%d\n",now.t);
            return ;
        }
        next=now;//a->b
        int s=next.a+next.b;
        if(b>=s)
            next.b=s;
        else
            next.b=b;
        next.a=s-next.b;
        if(judge(next))
        {
            next.t++;
            vis[next.a][next.b][next.c]=true;
            q.push(next);
        }
        next=now;//b->a
        s=next.a+next.b;
        if(a>=s)
            next.a=s;
        else
            next.a=a;
        next.b=s-next.a;
        if(judge(next))
        {
            next.t++;
            vis[next.a][next.b][next.c]=true;
            q.push(next);
        }
        next=now;//a->c
        s=next.a+next.c;
        if(c>=s)
            next.c=s;
        else
            next.c=c;
        next.a=s-next.c;
        if(judge(next))
        {
            next.t++;
            vis[next.a][next.b][next.c]=true;
            q.push(next);
        }
        next=now;//c->a
        s=next.a+next.c;
        if(a>=s)
            next.a=s;
        else
            next.a=a;
        next.c=s-next.a;
        if(judge(next))
        {
            next.t++;
            vis[next.a][next.b][next.c]=true;
            q.push(next);
        }
        next=now;//b->c
        s=next.b+next.c;
        if(c>=s)
            next.c=s;
        else
            next.c=c;
        next.b=s-next.c;
        if(judge(next))
        {
            next.t++;
            vis[next.a][next.b][next.c]=true;
            q.push(next);
        }
        next=now;//c->b
        s=next.b+next.c;
        if(b>=s)
            next.b=s;
        else
            next.b=b;
        next.c=s-next.b;
        if(judge(next))
        {
            next.t++;
            vis[next.a][next.b][next.c]=true;
            q.push(next);
        }
    }
    printf("NO\n");
}
int main()
{
    int a,b,c;
    while(scanf("%d%d%d",&a,&b,&c)&&(a||b||c))
    {
        memset(vis,false,sizeof(vis));
        bfs(a,b,c);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值