ZOJ 3635 Cinema in Akiba【线段树】

Cinema in Akiba


Time Limit: 3 Seconds      Memory Limit: 65536 KB

Cinema in Akiba (CIA) is a small but very popular cinema in Akihabara. Every night the cinema is full of people. The layout of CIA is very interesting, as there is only one row so that every audience can enjoy the wonderful movies without any annoyance by other audiences sitting in front of him/her.

The ticket for CIA is strange, too. There are n seats in CIA and they are numbered from 1 to n in order. Apparently, n tickets will be sold everyday. When buying a ticket, if there are k tickets left, your ticket number will be an integer i (1 ≤ ik), and you should choose the ith empty seat (not occupied by others) and sit down for the film.

On November, 11th, n geeks go to CIA to celebrate their anual festival. The ticket number of the ith geek is ai. Can you help them find out their seat numbers?

Input

The input contains multiple test cases. Process to end of file.
The first line of each case is an integer n (1 ≤ n ≤ 50000), the number of geeks as well as the number of seats in CIA. Then follows a line containing n integers a1, a2, ..., an (1 ≤ ain - i + 1), as described above. The third line is an integer m (1 ≤ m ≤ 3000), the number of queries, and the next line is m integers, q1, q2, ..., qm (1 ≤ qin), each represents the geek's number and you should help him find his seat.

Output

For each test case, print m integers in a line, seperated by one space. The ith integer is the seat number of the qith geek.

Sample Input
3
1 1 1
3
1 2 3
5
2 3 3 2 1
5
2 3 4 5 1
Sample Output
1 2 3
4 5 3 1 2


恩,题目大意就是说,电影院只有一排座位,每个到的人做的是第 ai 个空位置,然后问第 qi 个人所做的位置


#include <iostream>
#include<cstdio>
#include<cstring>
#define maxn 50000+10
using namespace std;
struct lnode
{
    int l,r,c;
};
lnode node[maxn<<2];
int ans[maxn];
void pushup(int o)
{
    node[o].c=node[o<<1].c+node[o<<1|1].c;
}
void build(int o,int l,int r)
{
    node[o].l=l;
    node[o].r=r;
    node[o].c=r-l+1;
    if(l==r)
        return ;
    int mid=(l+r)>>1;
    build(o<<1,l,mid);
    build(o<<1|1,mid+1,r);
}
int update(int o,int a)
{
    if(node[o].l==node[o].r)
    {
        node[o].c=0;
        return node[o].l;
    }
    int ans=0;
    if(a<=node[o<<1].c)
        ans=update(o<<1,a);
    else
        ans=update(o<<1|1,a-node[o<<1].c);
    pushup(o);
    return ans;
}
int main()
{
    int n,m,a;
    while(~scanf("%d",&n))
    {
        memset(ans,0,sizeof(ans));
        build(1,1,n);
        for(int i=1;i<=n;++i)
        {
            scanf("%d",&a);
            ans[i]=update(1,a);
        }
        scanf("%d",&m);
        for(int i=1;i<=m;++i)
        {
            scanf("%d",&a);
            if(i!=m)
                printf("%d ",ans[a]);
            else
                printf("%d\n",ans[a]);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值