POJ 2352 Stars 【树状数组】

Stars

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 38952 Accepted: 16944

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.


恩,题目大意就是说,星星按纵坐标从小到大,问的是一个星星在它左下角的星星个数就为该星星的等级,最后让输出从0到n-1 级的星星的个数,这里树状数组直接求 x 之前坐标的星星个数而忽略纵坐标,这里我离散化了一下,因为数组的大小WA了两次,应该不离散化也可以


#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 32010
using namespace std;
int n,c[maxn],l[maxn];
int x[maxn],y[maxn],r[maxn];
int lowbit(int t)
{
    return t&(t^(t-1));
}
void update(int x)
{
    for(int i=x;i<=n;i+=lowbit(i))
        c[i]++;
}
int sum(int x)
{
    int ans=0;
    for(int i=x;i>0;i-=lowbit(i))
        ans+=c[i];
    return ans;
}
int bsearch(int x,int ll,int rr)
{
    while(ll<=rr)
    {
        int mid=(ll+rr)>>1;
        if(r[mid]==x)
            return mid;
        if(r[mid]>x)
            rr=mid-1;
        else
            ll=mid+1;
    }
    return 0;
}
int main()
{
    while(~scanf("%d",&n))
    {
        int k=0;
        memset(c,0,sizeof(c));
        memset(l,0,sizeof(l));
        for(int i=0;i<n;++i)
        {
            scanf("%d%d",&x[i],&y[i]);
            r[++k]=x[i];
        }
        sort(r+1,r+k+1);
        int j=2;
        for(int i=2;i<=k;++i)
        {
            if(r[i]!=r[i-1])
                r[j++]=r[i];
        }
        for(int i=0;i<n;++i)
        {
            int xx=bsearch(x[i],1,j);
            l[sum(xx)]++;
            update(xx);
        }
        for(int i=0;i<n;++i)
            printf("%d\n",l[i]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值