POJ 3067 Japan 【树状数组 向下更新 向上求和】

Japan
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 23984 Accepted: 6492

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output:
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5


恩,题目大意就是说,有N个城市在东海岸,M个城市在西海岸,都从1开始标号,然后一个东海岸的城市和一个西海岸的城市之间建一条高速公路,相当于两岸的城市是一一相对的,然后问每条高速公路都和其他的高速公路有几个交点,然后每个高速公路的这个值都相加即为所求。然后这里的处理是先对 x 排序,从小到大,当 x 相同时 y 小优先,之后就看当前的 y 在它之前有多少个比它大的值,然后每个都相加即为最后结果。这里我敲代码时突然想起来要求有多少个比它大的,在更新时就要往下更新,而求和时往上求,还有就是更新时要更新到 y-1 因为  2 3 和 3 3 是不相交的。


#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 1000010
#define ll long long
using namespace std;
ll n,m,mx,c[maxn];
struct node
{
    int x,y;
};
node r[maxn];
int cmp(node a,node b)
{
    if(a.x!=b.x)
        return a.x<b.x;
    else
        return a.y<b.y;
}
ll maxi(ll a,ll b)
{
    return a>b?a:b;
}
int lowbit(int t)
{
    return t&(t^(t-1));
}
void update(int x)
{
    for(int i=x;i>0;i-=lowbit(i))
        c[i]++;
}
ll sum(int x)
{
    ll ans=0;
    for(int i=x;i<=mx;i+=lowbit(i))
        ans+=c[i];
    return ans;
}
int main()
{
    int t,cnt=0;
    long long k;
    scanf("%d",&t);
    while(t--)
    {
        memset(c,0,sizeof(c));
        scanf("%lld%lld%lld",&n,&m,&k);
        mx=-1;
        for(int i=0;i<k;++i)
        {
            scanf("%d%d",&r[i].x,&r[i].y);
            mx=maxi(mx,maxi(r[i].x,r[i].y));
        }
        sort(r,r+k,cmp);
        ll tem=0;
        for(int i=0;i<k;++i)
        {
            tem+=sum(r[i].y);
            update(r[i].y-1);
        }
        printf("Test case %d: %lld\n",++cnt,tem);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值