POJ 2309 BST 【lowbit()过】

BST
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9189 Accepted: 5620

Description

Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries. 

Input

In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 2 31 - 1).

Output

There are N lines in total, the i-th of which contains the answer for the i-th query.

Sample Input

2
8
10

Sample Output

1 15
9 11

恩,题目大意就是说,上面那幅图,给出一个节点,输出该节点的左子树的左子树的。。。。一直到最底层的最小值,和该节点的右子树的右子树的最底层的最大值,奇数就是它本身输出也要有最小值和最大值,至于偶数,判断一下lowbit(n)的值,若和它本身相等,就是1 和 n+n-1 若不等,则是 n -lowbit(n)+1 和 n+lowbit(n)-1;


#include <iostream>
#include<cstdio>
#include<cstring>
#define LL long long
using namespace std;

LL lowbit(LL t)
{
    return t&(t^(t-1));
}

int main()
{
    LL n;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&n);
        if(n&1)
            printf("%lld %lld\n",n,n);
        else
        {
            LL tem=lowbit(n);
            if(tem==n)
                printf("1 %lld\n",n+n-1);
            else
                printf("%lld %lld\n",n-tem+1,n+tem-1);
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值