POJ 3190 Stall Reservations 【贪心 区间】

Stall Reservations
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4325 Accepted: 1547 Special Judge

Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. 

Help FJ by determining:
  • The minimum number of stalls required in the barn so that each cow can have her private milking period
  • An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.

Output

Line 1: The minimum number of stalls the barn must have. 

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
4 7

Sample Output

4
1
2
3
2
4

Hint

Explanation of the sample: 

Here's a graphical schedule for this output: 

Time     1  2  3  4  5  6  7  8  9 10

Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..

Stall 3 .. .. c3>>>>>>>>> .. .. .. ..

Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.

恩,题目大意就是说,给出每头牛的区间范围,一台机器在同一时间只能为一头牛服务,问最少需要多少台机器。不细心,赋错值卡了一天了。。。。


#include <iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
#define maxn 50050
using namespace std;
int r[maxn];
struct node
{
    int s,e,p;
};
node cow[maxn];
bool cmp(node a,node b)
{
    if(a.s!=b.s)
        return a.s<b.s;
    return a.e<b.e;
}
struct Node
{
    int time,pos;
    friend bool operator < (Node a,Node b)
    {
        if(a.time!=b.time)
            return a.time > b.time;
        else
            return a.pos > b.pos;
    }
};
priority_queue<Node>q;

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        while(!q.empty())
            q.pop();
        memset(r,0,sizeof(r));
        for(int i=1;i<=n;++i)
        {
            scanf("%d%d",&cow[i].s,&cow[i].e);
            cow[i].p=i;
        }
        sort(cow+1,cow+n+1,cmp);
        int k=0;
        Node now={cow[1].e,cow[1].p};
        q.push(now);
        r[cow[1].p]=++k;
        for(int i=2;i<=n;++i)
        {
            now=q.top();
            if(cow[i].s<=now.time)
                r[cow[i].p]=++k;
            else
            {
                r[cow[i].p]=r[now.pos];
                q.pop();
            }
            now={cow[i].e,cow[i].p};
            q.push(now);
        }
        printf("%d\n",k);
        for(int i=1;i<=n;++i)
            printf("%d\n",r[i]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值