HDOJ 5611 Baby Ming and phone number

Baby Ming and phone number

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 736    Accepted Submission(s): 220


Problem Description
Baby Ming collected lots of cell phone numbers, and he wants to sell them for money.

He thinks normal number can be sold for b yuan, while number with following features can be sold for a yuan.

1.The last five numbers are the same. (such as 123-4567-7777)

2.The last five numbers are successive increasing or decreasing, and the diffidence between two adjacent digits is 1 . (such as 188-0002-3456)

3.The last eight numbers are a date number, the date of which is between Jar 1st, 1980 and Dec 31th, 2016. (such as 188-1888-0809,means August ninth,1888)

Baby Ming wants to know how much he can earn if he sells all the numbers.
 

Input
In the first line contains a single positive integer T , indicating number of test case.

In the second line there is a positive integer n , which means how many numbers Baby Ming has.(no two same phone number)

In the third line there are 2 positive integers a,b , which means two kinds of phone number can sell a yuan and b yuan.

In the next n lines there are n cell phone numbers.(|phone number|==11, the first number can’t be 0)

1T30,b<1000,0<a,n100,000
 

Output
How much Baby Nero can earn.
 

Sample Input
  
  
1 5 100000 1000 12319990212 11111111111 22222223456 10022221111 32165491212
 

Sample Output
  
  
302000



#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[20];
int rn(int n)
{
    if((n%4==0&&n%100)||(n%400==0))
        return 1;
    return 0;
}
int judge(char s[])
{
    int month[12]={31,28,31,30,31,30,31,31,30,31,30,31};
    if(s[6]==s[7]&&s[7]==s[8]&&s[8]==s[9]&&s[9]==s[10])
        return 1;
    if(s[7]-s[6]==1&&s[8]-s[7]==1&&s[9]-s[8]==1&&s[10]-s[9]==1)
        return 1;
    if(s[6]-s[7]==1&&s[7]-s[8]==1&&s[8]-s[9]==1&&s[9]-s[10]==1)
        return 1;
    int yy=(s[3]-'0')*1000+(s[4]-'0')*100+(s[5]-'0')*10+s[6]-'0';
    int mm=(s[7]-'0')*10+s[8]-'0';
    int dd=(s[9]-'0')*10+s[10]-'0';
    if(yy>=1980&&yy<=2016)
    {
        if(rn(yy))
            month[1]++;
        if(mm>=1&&mm<=12)
        {
            if(dd>=1&&dd<=month[mm-1])
                return 1;
        }
    }
    return 0;
}
int main()
{
    int t,n,a,b;
    __int64 sum;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        scanf("%d%d",&a,&b);
        sum=0;
        while(n--)
        {
            scanf("%s",s);
            if(judge(s))
                sum+=a;
            else
                sum+=b;
        }
        printf("%I64d\n",sum);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值