HDOJ 1220 Cube【数学推理】

Cube

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1734    Accepted Submission(s): 1379


Problem Description
Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.

Process to the end of file.
 

Input
There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).
 

Output
For each test case, you should output the number of pairs that was described above in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
0 16 297
Hint
Hint
The results will not exceed int type.

恩,题意大致是,边长为N的立方体,要切成N*N*N个边长为1的小立方体,两个小立方体的公共顶点个数不超过2的这样的立方体对共有多少对。切割之后立方体之间公共顶点的个数只有0,1,2,4,这几种情况,用总的减去公共顶点为4的即可。总的为n*n*n*(n*n*n-1)/2公共顶点为4的要分别算,下面代码里有计算公式。


#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
    int n;
    __int64 s,t;
    while(~scanf("%d",&n))
    {
        if(n==1)
        {
            printf("0\n");
            continue;
        }
        s=n*n*n*(n*n*n-1)/2;
        t=8*3/2+(n-2)*4*3*4/2+(n-2)*(n-2)*6*5/2+(n-2)*(n-2)*(n-2)*6/2;
        s=s-t;
        printf("%I64d\n",s);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值