HDU 2588 GCD 【利用欧拉函数求约数个数】

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1319    Accepted Submission(s): 596


Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
 


 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
 


 

Output
For each test case,output the answer on a single line.
 


 

Sample Input
  
  
3 1 1 10 2 10000 72
 


 

Sample Output
  
  
1 6 260

 

 

 

嗯,一看这题就试了一下普通方法不出意外的十分十分慢,然后根本想不到这题与欧拉函数的关系,也是看的人家题解才明白

其实就是求n的约数中大于m的个数,求出n的所有约数在找出大于m的个数,但是直接用普通方法求的话因为数据很大肯定超

时特别慢,然后这里设n%i==0&&i>=m,设p=n/i; j=euler(p)为小于p的与p互质的个数,为p1,p2,.....pj(1<=k<=j);然后
gcd(i*pk,n)==i>=m,所以这时总个数s=s+j;当然啦,当p>=m时,s+=euler(i);然后找到所有情况即可。

 

#include <iostream>
#include<cstdio>
#define maxn 1000000000+10
using namespace std;
int euler(int n)
{
    int r=n;
    if(n==1)
        return 1;
    for(int i=2;i*i<=n;++i)
    {
        if(n%i==0)
        {
            r=r/i*(i-1);
            while(n%i==0)
                n=n/i;
        }
    }
    if(n!=1)
        r=r/n*(n-1);
    return r;
}
int solve(int n,int m)
{
    int s=0;
    for(int i=1;i*i<=n;++i)//因为下面判断了n/i>=m的情况,所以这里i*i<=n即可
    {
        if(n%i)
            continue;
        if(i>=m&&i*i!=n)//这里i*i!=n是为了避免与下一个if判断重复
            s+=euler(n/i);
        if(n/i>=m)
            s+=euler(i);
    }
    return s;
}
int main()
{
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        printf("%d\n",solve(n,m));
    }
    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值