HDOJ 5586 Sum【最大子段和 动态规划 O(n)】

Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1324    Accepted Submission(s): 666


Problem Description
There is a number sequence  A1,A2....An ,you can select a interval [l,r] or not,all the numbers  Ai(lir)  will become  f(Ai) . f(x)=(1890x+143)mod10007 .After that,the sum of n numbers should be as much as possible.What is the maximum sum?
 

Input
There are multiple test cases.
First line of each case contains a single integer n. (1n105)
Next line contains n integers  A1,A2....An . (0Ai104)
It's guaranteed that  n106 .
 

Output
For each test case,output the answer in a line.
 

Sample Input
  
  
2 10000 9999 5 1 9999 1 9999 1
 

Sample Output
  
  
19999 22033
 

Source

先预处理,可得出变换前后的差值,求这些差值的最大子段和,然后再加上原先的总和。


#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define maxn 100010
#define MOD 10007
using namespace std;
__int64 a[maxn];
int s[maxn];
int r[maxn];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int sum=0;
        for(int i=1;i<=n;++i)
        {
            scanf("%I64d",&a[i]);
            s[i]=(a[i]*1890+143)%MOD;
            r[i]=s[i]-a[i];
            sum+=a[i];
        }
        int tem=0,ans=0;
        for(int i=1;i<=n;++i)
        {
            if(tem>=0)
                tem=(tem+r[i]);
            else
                tem=r[i];
            if(tem>ans)
                ans=tem;
        }
        printf("%d\n",ans+sum);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值