HDOJ 5120 Intersection【求圆与圆的交叉部分面积】

Intersection

Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1874    Accepted Submission(s): 715


Problem Description
Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.


A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.


Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.
 

Input
The first line contains only one integer T (T ≤ 10 5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers x i, y i (0 ≤ x i, y i ≤ 20) indicating the coordinates of the center of each ring.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.
 

Sample Input
  
  
2 2 3 0 0 0 0 2 3 0 0 5 0
 

Sample Output
  
  
Case #1: 15.707963 Case #2: 2.250778
 

Source


不理解为什么我保留8位小数就WA,非得6位才行


#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
double r,R,xr,yr,xR,yR;
const double pi=acos(-1.0);
double ins(double r,double R)
{
    double dis=sqrt((xr-xR)*(xr-xR)+(yr-yR)*(yr-yR));
    if(dis+r<=R)
        return pi*r*r;
    else if(r+R<=dis)
        return 0;
    else
    {
        double th1=acos((R*R+dis*dis-r*r)/(2*R*dis));
        double s=R*dis*sin(th1);
        double th2=acos((r*r+dis*dis-R*R)/(2*r*dis));
        double area=th1*R*R+th2*r*r-s;
        return area;
    }
}
int main()
{
    int t,num=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf",&r,&R);
        scanf("%lf%lf%lf%lf",&xr,&yr,&xR,&yR);
        double ans=ins(R,R)+ins(r,r)-ins(r,R)*2;
        printf("Case #%d: %.6lf\n",++num,ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值