HDOJ 5927 Auxiliary Set【树】

Auxiliary Set

Time Limit: 9000/4500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 689    Accepted Submission(s): 209


Problem Description
Given a rooted tree with n vertices, some of the vertices are important.

An auxiliary set is a set containing vertices satisfying at least one of the two conditions:

It is an important vertex
It is the least common ancestor of two different important vertices.

You are given a tree with n vertices (1 is the root) and q queries.

Each query is a set of nodes which indicates the unimportant vertices in the tree. Answer the size (i.e. number of vertices) of the auxiliary set for each query.
 


Input
The first line contains only one integer T ( T1000 ), which indicates the number of test cases.

For each test case, the first line contains two integers n ( 1n100000 ), q ( 0q100000 ).

In the following n -1 lines, the i-th line contains two integers ui,vi(1ui,vin) indicating there is an edge between ui i and vi in the tree.

In the next q lines, the i-th line first comes with an integer mi(1mi100000) indicating the number of vertices in the query set.Then comes with mi different integers, indicating the nodes in the query set.

It is guaranteed that qi=1mi100000 .

It is also guaranteed that the number of test cases in which n1000   or qi=1mi1000 is no more than 10.
 


Output
For each test case, first output one line "Case #x:", where x is the case number (starting from 1).

Then q lines follow, i-th line contains an integer indicating the size of the auxiliary set for each query.
 


Sample Input
  
  
1 6 3 6 4 2 5 5 4 1 5 5 3 3 1 2 3 1 5 3 3 1 4
 


Sample Output
  
  
Case #1: 3 6 3
Hint
For the query {1,2, 3}: •node 4, 5, 6 are important nodes For the query {5}: •node 1,2, 3, 4, 6 are important nodes •node 5 is the lea of node 4 and node 3 For the query {3, 1,4}: • node 2, 5, 6 are important nodes
 


Source


一棵根为1的树 给出不重要的点 求这个集合的大小  这个集合包括重要的点和有两个重要的子孙的不重要的点 所以我们要做的就是判断哪些不重要的点拥有两个以上的重要子孙然后进入集合 当时做的时候 就只是按照输入顺序判断当前点的儿子个数然后改变当前点的父亲的儿子数 计算结果后再恢复原值 结果当然错了 遇到这种数据会错

1-2 2-4 2-5 1-3 3-6 3-7 不重要的点: 1 2 3 5 6 结果会错运行结果会是5但其实是3啊 如果不重要的点的顺序变为 5 6 2 3 1 结果会不一样 所以对于不重要的点按当前的深度排序在判断修改值即可 同时标记哪个点改变了 改变了多少 之后还要恢复原值的。


//当时做没想到将不重要的点进行深度排序
#include <iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
#define maxn 100010
using namespace std;
int cnt,head[maxn];
int son[maxn],fa[maxn];
int rec[maxn],deep[maxn];
int mark[maxn];
struct Edge {
    int u,v,next;
}edge[maxn*2];
void init(){
    cnt=0;
    memset(head,-1,sizeof(head));
    memset(son,0,sizeof(son));
    memset(fa,0,sizeof(fa));
    memset(deep,0,sizeof(deep));
}
void add(int u,int v){
    Edge E={u,v,head[u]};
    edge[cnt]=E;
    head[u]=cnt++;
}
bool cmp(int a,int b){
    return deep[a] > deep[b];
}
void dfs(int u,int f){
    fa[u]=f;
    for(int i=head[u];i!=-1;i=edge[i].next){
        int v=edge[i].v;
        if(v!=f){
            deep[v]=deep[u]+1;
            son[u]++;
            dfs(v,u);
        }
    }
}
int main(){
    int t,n,q,m,u,v,ans,cnt=0;
    scanf("%d",&t);
    while(t--){
        init();
        scanf("%d%d",&n,&q);
        for(int i=1;i<n;++i){
            scanf("%d%d",&u,&v);
            add(u,v);
            add(v,u);
        }
        dfs(1,0);
        printf("Case #%d:\n",++cnt);
        while(q--){
            scanf("%d",&m);
            ans=n-m;
            int tem;
            for(int i=0;i<m;++i)
                scanf("%d",&rec[i]);
            sort(rec,rec+m,cmp);
            for(int i=0;i<m;++i){
                if(son[rec[i]]>=2)
                    ans++;
                else if(son[rec[i]]==0){
                    son[fa[rec[i]]]--;
                    mark[fa[rec[i]]]++;
                }
            }
            for(int i=0;i<m;++i){
                if(mark[fa[rec[i]]]){
                    son[fa[rec[i]]]+=mark[fa[rec[i]]];
                    mark[fa[rec[i]]]=0;
                }
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值