F - Auxiliary Set
Given a rooted tree with n vertices, some of the vertices are important.An auxiliary set is a set containing vertices satisfying at least one of the two conditions:
∙∙It is an important vertex
∙∙It is the least common ancestor of two different important vertices.
You are given a tree with n vertices (1 is the root) and q queries.
Each query is a set of nodes which indicates the unimportant vertices in the tree. Answer the size (i.e. number of vertices) of the auxiliary set for each query.
Input
The first line contains only one integer T (T≤1000T≤1000), which indicates the number of test cases.
For each test case, the first line contains two integers n (1≤n≤1000001≤n≤100000), q (0≤q≤1000000≤q≤100000).
In the following n -1 lines, the i-th line contains two integers ui,vi(1≤ui,vi≤n)ui,vi(1≤ui,vi≤n) indicating there is an edge between uiuii and vivi in the tree.
In the next q lines, the i-th line first comes with an integer mi(1≤mi≤100000)mi(1≤mi≤100000) indicating the number of vertices in the query set.Then comes with mi different integers, indicating the nodes in the query set.
It is guaranteed that ∑qi=1mi≤100000∑i=1qmi≤100000.
It is also guaranteed that the number of test cases in which n≥1000n≥1000 or ∑qi=1mi≥1000∑i=1qmi≥1000 is no more than 10.
Output
For each test case, first output one line "Case #x:", where x is the case number (starting from 1).
Then q lines follow, i-th line contains an integer indicating the size of the auxiliary set for each query.
Sample Input
1
6 3
6 4
2 5
5 4
1 5
5 3
3 1 2 3
1 5
3 3 1 4
Sample Output
Case #1:
3
6
3
Hint
For the query {1,2, 3}:
•node 4, 5, 6 are important nodes For the query {5}:
•node 1,2, 3, 4, 6 are important nodes
•node 5 is the lea of node 4 and node 3 For the query {3, 1,4}:
• node 2, 5, 6 are important nodes
•node 4, 5, 6 are important nodes For the query {5}:
•node 1,2, 3, 4, 6 are important nodes
•node 5 is the lea of node 4 and node 3 For the query {3, 1,4}:
• node 2, 5, 6 are important nodes
G
题意:
题意:
给你一棵树,有n个节点,q次查询,每次查询告诉你m个非重要节点(其余都是重要节点),问你每次查询时Auxiliary Set元素有多少个?
满足一下两点中的一点即可为Auxiliary Set元素:
1:是重要节点
2:是两个重要节点的最近公共祖先
思路:
把不是重要的点按照深度排序,然后按照孩子的个数来判断这个点是不是能够加到集合里。
对于m个不重要节点,按深度从大到小排序,然后依次判断:对于当前点,
如果它的儿子数量大于等于2,说明他有两个重要节点孩子,那么当前点一定是一个重要节点;
如果儿子数量等于1,那么关系到当前点的祖先节点是不是重要节点,不处理;
如果孩子数等于0,那么当前点肯定不是重要节点,同时其父亲节点的儿子数量减1
只要满足孩子数大于等于2的都是Auxiliary Set元素。
代码:
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
const int maxx=1e5+10;
using namespace std;
vector<int>s[maxx];
int fa[maxx]; //父节点
int son[maxx]; //子节点个数
int deep[maxx]; //深度
int vis[maxx];
int uu[maxx];
int temp[maxx]; //多组数据,代替son
void dfs(int u,int f,int d)
{
vis[u]=1;
fa[u]=f;
deep[u]=d; //深度
for(int i=0,l=s[u].size();i<l;i++) //遍历与u连接的点
{
int v=s[u][i];
if(!vis[v])
{
son[u]++; //点u的子节点个数
dfs(v,u,d+1); //遍历u的子节点v,此时v的父节点是u,深度+1
}
}
}
int cmp(int a,int b)
{
return deep[a]>deep[b]; //从底看
}
int main()
{
int T;
scanf("%d",&T);
int n,q;
for(int num=1;num<=T;num++)
{
scanf("%d %d",&n,&q);
for(int i=1;i<=n;i++)
{
s[i].clear();
vis[i]=0;
son[i]=0;
}
int u,v;
for(int i=0;i<n-1;i++)
{
scanf("%d %d",&u,&v);
s[u].push_back(v);
s[v].push_back(u);
}
dfs(1,0,0);
int m;
printf("Case #%d:\n",num);
while(q--)
{
scanf("%d",&m);
int sum=n-m;
for(int i=0;i<m;i++)
{
scanf("%d",&uu[i]);
temp[uu[i]]=son[uu[i]];
}
sort(uu,uu+m,cmp);
for(int i=0;i<m;i++) //找两个重要节点的最近公共子节点
{
if(temp[uu[i]]>=2)
sum++;
else if(temp[uu[i]]==0) //只有一个子节点,一定不是重要节点
temp[fa[uu[i]]]--; //该节点的父亲节点的儿子数量-1,排除父亲节点的非重要节点。
}
printf("%d\n",sum);
}
}
return 0;
}