Battle Over Cities (25)
It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.
Input
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0
题目大意:给n个城市m 条路 k个询问 然后是m条路 之后是询问,询问是 如果没有城市q1/q2/…./qk 需要建多少条路
分析:并查集 开始以为是并查集删点 自己写着写着发现是删边 先存边 然后不管与qk有关的边 求共有几个连通块 唯一担心会超时 不过n<1000 总数减二 因为总数中包括了要删除的城市 其次 n个连通块 需n-1条路 所以最后ans-2
#include <iostream>
#include<cstdio>
#include<cstring>
#define maxn 1010
#define maxm 1000010//数组开小 一个测试点没过
using namespace std;
int n,m,pre[maxn];
struct node{
int u,v;
}edge[maxm];
void init(){
for(int i=0;i<=n;++i)
pre[i]=i;
}
int find_p(int x){
return x==pre[x]?x:pre[x]=find_p(pre[x]);
}
void join(int a,int b){
int fa=find_p(a);
int fb=find_p(b);
if(fa!=fb)
pre[fa]=fb;
}
int main()
{
int k,q,ans;
bool vis[maxn];
scanf("%d%d%d",&n,&m,&k);
for(int i=0;i<m;++i)
scanf("%d%d",&edge[i].u,&edge[i].v);
while(k--){
init();
scanf("%d",&q);
for(int i=0;i<m;++i){
if(edge[i].u!=q&&edge[i].v!=q){
join(edge[i].u,edge[i].v);
}
}
int ans=0;
memset(vis,false,sizeof(vis));
for(int i=1;i<=n;++i){
int tem=find_p(i);
if(!vis[tem]){
vis[tem]=true;
ans++;
}
}
printf("%d\n",ans-2);
}
return 0;
}