Reversible Primes (20)
A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line “Yes” if N is a reversible prime with radix D, or “No” if not.
Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
题目大意:给十进制数n 和进制d 多组数据 n<0输入结束 首先判断n是否为素数 然后将n转换为d进制 再反转 然后再转换为十进制 判断是否为素数 如果两个数都为素数 则输出”Yes”否则输出”No”
分析:读懂题意 按步骤解题即可
#include <iostream>
#include<cstdio>
#include<cstring>
#define maxn 100010
using namespace std;
int mark[maxn]={0};
char s[maxn];
void init(){
memset(mark,0,sizeof(mark));
mark[0]=mark[1]=1;
for(int i=2;i<maxn;++i){
if(mark[i])
continue;
for(int j=i*2;j<maxn;j+=i){
if(!mark[j])
mark[j]=1;
}
}
}
void d_trans(int n,int d){//转换为d进制的同时反转
int i=0;
while(n){
s[i]='0'+n%d;
n=n/d;
i++;
}
s[i]='\0';//加上字符串结束符
}
int trans_d(char ss[maxn],int d){
int ans=0;
int lens=strlen(ss);
for(int i=0;i<lens;++i){//d进制转换为十进制
ans=ans*d;
ans+=ss[i]-'0';
}
return ans;
}
int main()
{
int n,d;
init();
while(scanf("%d",&n)&&n>=0){
scanf("%d",&d);
if(mark[n]){
printf("No\n");
continue;
}
d_trans(n,d);
int val=trans_d(s,d);
if(!mark[val])
printf("Yes\n");
else
printf("No\n");
}
return 0;
}