c语言Number Sequence

Problem Description A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output For each test case, print the value of f(n) on a single line.

Sample Input1 1 3
1 2 10
0 0 0

Sample Output2
5

错误代码超时了,最后借鉴·同学地才发现有规律

#include<stdio.h>
int main()
{
 int n,a,b,f[1000001],i,j;
 f[1]=1;
 f[2]=1;
 scanf("%d %d %d",&a,&b,&n);
 while(scanf("%d %d %d",&a,&b,&n)!=EOF)
  {
    if(a==0&&b==0&&n==0)
     return 0;
     for(i=3;i<=n;i++)
       {
        f[1]=1;
              f[2]=1;
         f[i]=(a*f[i-1]+b*f[i-2])%7;
         
    }
    printf("%d\n",f[n]);
  }
 } 

正确地代码:
49一循环,取余即可

#include <stdio.h>
int f(int a,int b,int n);
int main()
{
    int n,a,b;
    scanf("%d %d %d",&a,&b,&n);
 while(a!=0||b!=0||n!=0){
  a=a%7;
  b=b%7;
  n=n%48;
  printf("%d\n",f(a,b,n));
  scanf("%d %d %d",&a,&b,&n);
 }
    return 0;
}
int f(int a,int b,int n)
 {
 if(n==1){
  return 1;
 }else if(n==2){
  return 1;
 }else{
  return (a*f(a,b,(n-1))+b*f(a,b,(n-2)))%7;
 }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
下面是一个使用三个子函数实现从序列中删除数字的C语言程序: ```c #include <stdio.h> void inputSequence(int seq[], int n); // 输入序列 void outputSequence(int seq[], int n); // 输出序列 int deleteNumber(int seq[], int n, int num); // 删除数字 int main() { int n, num; printf("Enter the length of the sequence: "); scanf("%d", &n); int seq[n]; printf("Enter the sequence:\n"); inputSequence(seq, n); printf("Enter the number to delete: "); scanf("%d", &num); int newLen = deleteNumber(seq, n, num); if (newLen == n) printf("The number does not exist.\n"); else { printf("The new sequence:\n"); outputSequence(seq, newLen); } return 0; } // 输入序列 void inputSequence(int seq[], int n) { for (int i = 0; i < n; i++) scanf("%d", &seq[i]); } // 输出序列 void outputSequence(int seq[], int n) { for (int i = 0; i < n; i++) printf("%d ", seq[i]); printf("\n"); } // 删除数字 int deleteNumber(int seq[], int n, int num) { int i; for (i = 0; i < n; i++) { if (seq[i] == num) break; } if (i == n) return n; // 没找到要删除的数字,返回原长度 // 要删除的数字后面的元素向前移动一个位置 for (int j = i; j < n - 1; j++) { seq[j] = seq[j + 1]; } return n - 1; // 返回新长度 } ``` 程序首先通过 `inputSequence()` 函数从键盘输入序列,然后通过 `deleteNumber()` 函数删除指定的数字。如果序列中没有要删除的数字,该函数返回原长度,否则将后面的元素向前移动一个位置,返回新长度。最后,程序通过 `outputSequence()` 函数输出新序列。如果返回的新长度等于原长度,就说明要删除的数字不存在。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值