ACM--steps--4.2.3--A strange lift

16 篇文章 0 订阅

A strange lift

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 717 Accepted Submission(s): 350
 
Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button "UP" or "DOWN"?
 
Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 
Sample Input
5 1 5
3 3 1 2 5
0
 
Sample Output
3
 
 
 
Recommend
8600


#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
//首先构建结构体。
struct dyx
{
    int x,step;
    /*friend bool operator<(dyx a,dyx b)
    {
        return b.step<a.step;
    }*/
};
int n;//表示有几层楼。
int s,e;//表示刚开始所在的楼层s和最后结束的楼层e;
int step[209];//表示第几层有的那一个数字。
int vis[209];//表示状态的访问。
//进行状态的判断。
int wyx(int x)
{
    if(x<=0||x>n)
    return 1;
    return 0;
}
int bfs()
{
    //priority_queue<dyx> que;
    queue<dyx> que;
    dyx now,next;
    int i;
    now.x=s;
    now.step=0;
    vis[s]=1;//表示最初始状态已经被访问过。
    que.push(now);
    while(!que.empty())
    {
        now=que.front();
        que.pop();
        if(now.x==e)
        return now.step;
        for(i=-1;i<=1;i+=2)//因为是只有上下,所以上为1,下位-1;
        {
            next=now;
            next.x+=i*step[next.x];
            if(wyx(next.x)||vis[next.x])
            continue;
            vis[next.x]=1;
            next.step++;
            que.push(next);
        }
    }
    return -1;
}
int main()
{

    while(cin>>n&&n)
    {
        cin>>s>>e;
        for(int i=1;i<=n;i++)
        {
            cin>>step[i];
        }
        memset(vis,0,sizeof(vis));
        cout<<bfs()<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值