HDU:1021 Fibonacci Again

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 58425    Accepted Submission(s): 27361

题目链接
Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no
解题思路:
只要发现了题目的规律,这个题目就没什么难度,不可以盲目地去计算,因为n最大为1000000,如果硬是去求值,这个数特别大,这样是不可以的。下面是这个题目的规律。数组f用来表示按斐波那契额求的数,用F表示当前f[i]%3得到的数。
f[0]=7 F[0]=f[0]%3=1 F[0]=1 no
f[1]=11 F[1]=f[1]%3=2 F[1]=2 no
f[2]=f[1]+f[0]=18 F[2]=f[2]%3=0 并且可以看出 F[2]=(F[1]+F[0])%3=(2+1)%3=0 yes
f[3]=f[2]+f[1]=29 F[3]=f[3]%3=2 并且可以看出 F[3]=(F[2]+F[1])%3=(0+2)%3=2 no
f[4]=f[3]+f[2]=47 F[4]=f[4]%3=2 并且可以看出 F[4]=(F[3]+F[2])%3=(2+0)%3=2 no
f[5]=f[4]+f[3]=76 F[5]=f[5]%3=1 并且可以看出 F[5]=(F[4]+F[3])%3=(2+2)%3=1 no
f[6]=f[5]+f[4]=123 F[6]=f[6]%3=0 并且可以看出 F[6]=(F[5]+F[4])%3=(1+2)%3=0 yes
. . . .
. . . .
. . . .
看到上面的推导,其实规律已经很明显了。
#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

int F[1000002];
void Create_Table()
{
    F[0]=1;
    F[1]=2;
    for(int i = 2; i <= 1000000; i++)
        F[i]=(F[i-1]+F[i-2])%3;
}
int main()
{
    int n;
    Create_Table();
    while(~scanf("%d",&n))
    {
        if(F[n]==0)
            printf("yes\n");
        else
            printf("no\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值