HDU 2680:Choose the best route

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14226    Accepted Submission(s): 4651

点击打开题目链接
Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
  
  
1 -1
题目意思:Kiki要去他的朋友家。求一条最短路径。
第一行输入n,m,s.代表有n个车站(编号从1~n),接下来要给出m条直接相邻的路径(注意题目明确告诉了,两个点之前可能有多条路径),s代表与Kiki朋友家相邻的车站,接下来m行会给出p,q,t代表从车站p到车站q有一条路,耗费的时间是t(有向图)。然后给出w个站点,代表Kiki可以选择作为出发点的车站编号。
解题思路:
求出车站s到其他车站的最短路径即可。关键这个图是有向图,因此要求车站s到其他车站的最短路径,我们必须先将整个图进行反转。
然后求最短路就可以了。
#include<iostream>
#include<cstdio>
#include<queue>
#include<vector>
#include<cstring>
#include<string>
#include<stack>
#include<map>
#include<set>
#define INF 0x3f3f3f3f
#define MAXN 1002

using namespace std;

int n,m,s;
int Map[MAXN][MAXN];  ///存放地图
int dis[MAXN];
int vis[MAXN];
void InitMap()
{
    for(int i = 1; i <= n; i++)
    {
        Map[i][i] = 0;
        for(int j = i+1; j <= n; j++)
            Map[i][j] = Map[j][i] = INF;
    }
}
void Dijkstra()
{
    int mindis,u;
    for(int i = 1; i <= n; i++)
    {
        vis[i] = 0;
        dis[i] = Map[s][i];
    }
    vis[s] = 1;
    for(int i = 1; i <= n; i++)
    {
        mindis = INF;
        u = 0;
        for(int j = 1; j <= n; j++)
        {
            if(vis[j]==0 && dis[j]<mindis)
            {
                mindis = dis[j];
                u = j;
            }
        }
        if(u == 0) break;
        vis[u] = 1;
        for(int j = 1; j <= n; j++)
        {
            if(vis[j]==0)
            {
                if(dis[u]+Map[u][j]<dis[j])
                    dis[j] = dis[u]+Map[u][j];
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d%d",&n,&m,&s))
    {
        InitMap();
        int p,q,t;
        for(int i = 0; i < m; i++)
        {
            scanf("%d%d%d",&p,&q,&t);
            ///题目提示,两个站之间可能存在多条路径,选择最短的那一条,并进行道路逆置
            if(t<Map[q][p])  
                 Map[q][p] = t;
        }
        Dijkstra();
        int w;
        int node,mindis=INF;
        scanf("%d",&w);
        for(int i = 0; i < w; i++)
        {
            scanf("%d",&node);
            if(dis[node]<mindis)
                mindis = dis[node];
        }
        if(mindis < INF) printf("%d\n",mindis);
        else printf("-1\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值