HDU:1757 A Simple Math Problem


A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4788    Accepted Submission(s): 2876


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
  
  
45 104

解题思路:

矩阵快速幂题目。

线性代数没白学,好有用,不过这个题目推出矩阵是难点。

别人的图:画的真好,一目了然。



#include<iostream>
#include<stdio.h>
#include<string.h>

using namespace std;

const int maxn = 11;
int mod;   ///模
struct Matrix
{
    int m[maxn][maxn];
}ans,res;
///矩阵乘法,计算矩阵a*b。
Matrix Mul(Matrix a,Matrix b)
{
   Matrix tmp;
   memset(tmp.m,0,sizeof(tmp.m));
   for(int i = 1; i <= 10; i++)
       for(int j = 1; j <= 10; j++)
           for(int k = 1; k <= 10; k++)
               tmp.m[i][j] = (tmp.m[i][j]+a.m[i][k]*b.m[k][j])%mod;
   return tmp;
}
void QuickPower(int N)
{
    ///ans初始为单位矩阵,任何矩阵乘上单位阵都是其本身
    memset(ans.m,0,sizeof(ans.m));
    for(int i = 1; i <= 10; i++)
        ans.m[i][i] = 1;
    while(N)
    {
        if(N&1)
            ans = Mul(ans,res);
        res = Mul(res,res);
        N >>= 1;
    }
}
int main()
{
    int k;
    while(~scanf("%d%d",&k,&mod))
    {
        memset(res.m,0,sizeof(res.m));
        ///输入a[0]到a[9]
        for(int i = 1; i <= 10; i++)
        {
            scanf("%d",&res.m[1][i]);
            res.m[1][i] = res.m[1][i]%mod;
        }
        for(int i = 2; i <= 10; i++)
            res.m[i][i-1] = 1;
        if(k < 10)
            printf("%d\n",k);
        else
        {
            k = k-9;
            QuickPower(k);  ///矩阵快速幂
            int a = 0;
            for(int i = 1; i <= 10; i++)
            {
                a += ans.m[1][i]*(10-i);
                a = a%mod;
            }
            printf("%d\n",a);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值