2017年上海金马五校程序设计竞赛:Problem E : Find Palindrome


Problem E : Find Palindrome


 (Out of Contest)

Time Limit: 1 s

Description

Given a string S, which consists of lowercase characters, you need to find the longest palindromic sub-string.

A sub-string of a string S  is another string S'  that occurs "in" S. For example, "abst" is a sub-string of "abaabsta". A palindrome is a sequence of characters which reads the same backward as forward.

 

Input

There are several test cases.
Each test case consists of one line with a single string S (1 ≤ || ≤ 50).

 

Output

For each test case, output the length of the longest palindromic sub-string.

 

Sample Input

sasadasa
bxabx
zhuyuan

 

Sample Output

7
1
3

题目意思:

给出一个字符串,求这个字符串中的最长回文串的长度。

解题思路:

参加今年天梯赛前,去练去年天梯的题时,level2有个题,给一个字符串,然后把它反过来,然后求最长对称子串长度。其实就是求最长回文串长。

这次遇到一模一样的题目就很快做出了。

思路如下:

首先要一个一个看字符串中的字符:

对于第 i 个字符 str[i] ,假如回文子串是奇数个字符,那么考虑以i为中心,同时向左向右扩展,直到发现对称位置字符不相等,假如此时共扫过x

个字符,则当前回文串长度为2*x+1。加上的1就是加上i本身。如下图所示:



由第 i 个字符a[i]构成回文偶数串。i在最接近对称轴的左侧。


 

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#define INF 999999
 
using namespace std;
 
int main()
{
    int maxlen,i,j,len;   ///最长对称子串长度。
    char str[1003];
    while(gets(str))
    {
        maxlen = 0;
        len = strlen(str);
        for(i = 0; i < len; i++)
        {
            ///考虑是i是奇数串的中心,以i为中心,同时往左往右扩展
            for(j = 0; i-j>=0&&i+j<=len; j++)
            {
                if(str[i-j]!=str[i+j])
                    break;
                if(2*j+1>maxlen)
                    maxlen = 2*j+1;
            }
            ///i是偶数串的中心
            for(j = 0; i-j>=0&&i+j+1<len;j++)
            {
                if(str[i-j]!=str[i+j+1])
                    break;
                if(2*j+2>maxlen)
                    maxlen = 2*j+2;
            }
        }
        printf("%d\n",maxlen);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值