POJ - 2631 Roads in the North ( 求树的直径)

题目链接

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

求树的直径裸体,从一个点dfs找到最远的点,再从最远的这个点出发dfs找到最远的

之间的距离就是树的直径

#include <cstdio>
#include <cstring>
using namespace std;
typedef long long ll;
const int maxn=1e5+5;

struct edge
{
	int to,next,dis;
}e[maxn];
int head[maxn],d[maxn],vis[maxn],cnt,ans;
int node;
inline void addedge(int u,int v,int w)
{
	cnt++;
	e[cnt].to=v;
	e[cnt].next=head[u];
	e[cnt].dis=w;
	head[u]=cnt;
}
void dfs(int u,int fa)
{
	for(int i=head[u];i;i=e[i].next)
	{
		int v=e[i].to;
		if(!vis[v])
		{
			vis[v]=1;
			d[v]=fa+e[i].dis;
			if(d[v]>ans)
			{
				ans=d[v];
			    node=v;
			}
			dfs(v,d[v]);
		}
	}
}

int main()
{
	int u, v ,w;
	while(scanf("%d%d%d",&u,&v,&w)!=EOF)
	{
		addedge(u,v,w);
		addedge(v,u,w);
	}
	memset(vis,0,sizeof vis);
	vis[1]=1;
	ans=0;
	dfs(1,0);
	memset(vis,0,sizeof vis);
	vis[node]=1;
	ans=0;
	dfs(node,0);
	printf("%d\n", ans);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值