A == B ?

A == B ?

Describe
Give you two numbers A and B, if A is equal to B, you should print “YES”, or print “NO”.

Input
each test case contains two numbers A and B.

Output
for each case, if A is equal to B, you should print “YES”, or print “NO”.

Sample Input

1 2
2 2
3 3
4 3

Sample Output

NO
YES
YES
NO

看起来像水题,其实是大数比较,细节较多,需要去除前导0和后导0,还要注意是否除掉小数点,之后才能安安心心比较。

#include<iostream>
#include<cstring>

using namespace std;

char* change(char *a);

char a[100000],b[100000];

int main()
{   
    while(cin>>a>>b)
    {
        if(!strcmp(change(a),change(b)))
            cout<<"YES"<<endl;

        else cout<<"NO"<<endl;
    }
    return 0;
}

char* change(char *a)
{
    int len=strlen(a);
    if(strstr(a,"."))   
    {  
        int j=len-1;
        while(a[j]=='0')
        {
            a[j]='\0';
            j--;
            len--;
        } 
        if(a[j]=='.')  
            a[j]='\0';  
    } 
    if(a[0]=='0')   
    {  
        while(a[0]=='0')  
        {  
            for(int i=0;i<len-1;i++)  
                a[i]=a[i+1];  
            a[len-1]='\0';  
            len--;  
        }  
    }  
    return a;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值