A + B Problem II

A + B Problem II

Describe
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

大数加法格式化版,注意输出空行的个数。

#include<iostream>
#include<cstring>

using namespace std;

char a[1000],b[1000],res[1001];
char cha(char a);

void add();

int main()
{
    int t;
    cin>>t;
    for(int i=1;i<=t;i++)
    {
        cin>>a>>b;
        cout<<"Case "<<i<<":"<<endl<<a<<" + "<<b<<" = ";
        add();
        cout<<res<<endl;
        if(i==t) break;
        cout<<endl;
        memset(res,0,sizeof(res));
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
    }
    return 0;
}

void add()
{
    int len1,len2,len,i,j;
    len1=strlen(a);
    len2=strlen(b);
    len=max(len1,len2);
    strrev(a);
    strrev(b);
    for(i=0;i<len;i++)
    {
        char t=cha(res[i]);
        res[i]=(char)((t+(cha(a[i])+cha(b[i]))%10)%10+'0');
        res[i+1]=(t+cha(a[i])+cha(b[i]))/10+'0';
    }
    if(res[len]=='0') res[len]='\0';
    strrev(res);
    if(res[0]=='0')
    {
        for(i=0;res[0]=='0';i++)
        {   
            for(j=0;j<len;j++)
            {
                res[j]=res[j+1];
            }
        }
    }
}

char cha(char a)
{
    if(a!='\0') return a-'0';
    else return '\0';
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值