Hero
Describe
When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.
There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.
To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero’s HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.
Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
Output
Output one line for each test, indicates the minimum HP loss.
Sample Input
1
10 2
2
100 1
1 100
Sample Output
20
201
我们可以设定一种攻击优先度来确定我方英雄的攻击顺序,敌方hp越低,dps越高,我们优先打它,也就是说地方dps/hp越高越优先,但比例一样时,hp低的优先,如此排序之后模拟攻击回合即可。
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
struct node{
int hp;
int dps;
double rate;
}hero[21];
bool cmp(const node& a,const node& b)
{
if(a.rate==b.rate)
return a.hp<b.hp;
return a.rate>b.rate;
}
int main()
{
int n;
while(cin>>n)
{
int loss=0,killed=0;
for(int i=0;i<n;i++)
{
cin>>hero[i].dps>>hero[i].hp;
hero[i].rate=(double)hero[i].dps/(double)hero[i].hp;
}
sort(hero,hero+n,cmp);
int i=0;
while(1)
{
if(hero[i].hp==0) i++,killed++;
if(killed==n)
break;
hero[i].hp--;
for(int j=i;j<n;j++)
loss+=hero[j].dps;
}
cout<<loss<<endl;
memset(hero,0,sizeof(hero));
}
return 0;
}