POJ 2151 Check the difficulty of problems

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 
1. All of the teams solve at least one problem. 
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

Source

POJ Monthly,鲁小石

解题思路:简单概率DP。
#include <ctime>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn = 1010;
double P[maxn][40];
double dp1[maxn][40][40];
double dp2[maxn][40];
int M, T, N;

int main() {

    //freopen("aa.in", "r", stdin);

    while(scanf("%d %d %d", &M, &T, &N) != EOF) {
        if(M == 0 && T == 0 && N == 0) break;
        for(int i = 1; i <= T; ++i) {
            for(int j = 1; j <= M; ++j) {
                scanf("%lf", &P[i][j]);
            }
        }
        for(int i = 1; i <= T; ++i) {
            memset(dp1[i], 0, sizeof(dp1[i]));
            dp1[i][0][0] = 1.0;
            for(int j = 1; j <= M; ++j) {
                for(int k = 0; k <= j; ++k) {
                    dp1[i][j][k] = dp1[i][j-1][k]*(1.0-P[i][j]);
                    if(k > 0) {
                        dp1[i][j][k] += dp1[i][j-1][k-1]*P[i][j];
                    }
                }
            }
        }
        memset(dp2, 0, sizeof(dp2));
        for(int i = 1; i <= M; ++i) {
            dp2[1][i] = dp1[1][M][i];
        }
        for(int i = 2; i <= T; ++i) {
            dp2[i][1] = dp2[i-1][1] * dp1[i][M][1];
            for(int j = 2; j <= M; ++j) {
                for(int k = 1; k <= j; ++k) {
                    dp2[i][j] += dp2[i-1][k] * dp1[i][M][j];
                }
                for(int k = 1; k < j; ++k) {
                    dp2[i][j] += dp1[i][M][k] * dp2[i-1][j];
                }
            }
        }
        double ans = 0.0;
        for(int i = N; i <= M; ++i) {
            ans += dp2[T][i];
        }
        printf("%.3lf\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值