Hdu5776 字串的和[鸽巢原理]

题目连接

http://acm.hust.edu.cn/vjudge/problem/440424

Description

Given a sequence, you’re asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO

Input

The first line of the input has an integer T ( ), which represents the number of test cases.
For each test case, there are two lines:
1.The first line contains two positive integers n, m ( , ).
2.The second line contains n positive integers x ( ) according to the sequence.

Output

Output T lines, each line print a YES or NO.

Sample Input

2
3 3
1 2 3
5 7
6 6 6 6 6

Sample Output

YES
NO

题意

给出n个数字构成的串,问其中是否存在一个连续字串的和是m的倍数。

题解

对前缀和做取m余运算,可证若存在两个前缀和取余结果相同,则由这两个前缀和构成的字串的和是m的倍数[鸽巢原理可证]。对n为1时要特判一下。

代码

#include<iostream>
#include<queue>
  #include<cstdio>
  #include<cstring>
  #include<string>
  #include<cmath>
  #include<string>
 #include<cctype>
  #include<algorithm>
  #include<vector>
using namespace std;
const int maxn=100005;



int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {   int a[maxn];
        int b[maxn];
        int s[maxn];
        memset(b,0,sizeof(b));
        int n,m,sum=0;int ok=0;
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);

        }

        s[0]=a[0];
        for(int i=1;i<n;i++){a[i]+=a[i-1];s[i]=a[i];}
        for(int i=0;i<n;i++){s[i]%=m;b[s[i]]++;}

        for(int i=0;i<=m;i++)
        {
            if(b[i]>1){ok=1;break;}
            if(b[0]==1){ok=1;break;}
        }
        if(ok==1)printf("YES\n");
        else printf("NO\n");
    }

return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值