hdu5776 sum (鸽巢原理)

99 篇文章 2 订阅

sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2145    Accepted Submission(s): 803


Problem Description
Given a sequence, you're asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO
 

Input
The first line of the input has an integer T ( 1T10), which represents the number of test cases. 
For each test case, there are two lines:
1.The first line contains two positive integers n, m ( 1n100000 1m5000).
2.The second line contains n positive integers x ( 1x100) according to the sequence.
 

Output
Output T lines, each line print a YES or NO.
 

Sample Input
 
 
2 3 3 1 2 3 5 7 6 6 6 6 6
 

Sample Output
 
 
YES NO
 

Source
 

Recommend
鸽巢原理啊啊啊,组合数学43面详细讲解~~~
#include <iostream>
#include <string.h>
#include <cstdio>

using namespace std;

int mm[5020];

int main()
{
    int T;
    cin>>T;
    int n,m;
    int sum = 0;
    int flag = 0;
    while(T--){
        scanf("%d%d",&n,&m);
        int temp;
        for(int i = 0;i < n;i++){
            scanf("%d",&temp);
            sum += temp;
            mm[sum%m]++;
            if(mm[sum%m] == 2)flag = 1;
        }
        if(mm[0] != 0)flag = 1;
        if(n >= m)printf("YES\n");
        else{
            if(flag == 1)printf("YES\n");
            else{
                printf("NO\n");
            }
        }
        sum = 0;
        flag = 0;
        memset(mm,0,sizeof(mm));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值