Hdu 5775模拟冒泡[树状数组]

题目连接

http://acm.hust.edu.cn/vjudge/problem/435522

Description

P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.

for(int i=1;i<=N;++i)
for(int j=N,t;j>i;—j)
if(P[j-1] > P[j])
t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.

Input

The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.

Output

For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.

Sample Input

2
3
3 1 2
3
1 2 3

Sample Output

Case #1: 1 1 2
Case #2: 0 0 0

Hint

In first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3)
the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3
In second case, the array has already in increasing order. So the answer of every number is 0.

题意

模拟冒泡排序的过程,问一个数在移动的过程中,最右端可以移动到哪,最左端可以移动到哪,并求出d=最右端-最左端。

题解

首先注意到,题目中的冒泡排序的第二层是从后往前的,那么可知,最左端的位置一定是开始的初始位置与最终位置的较小值。因为从后往前,被动情况下只能向右移动,除非轮到自己,可以主动向左移动,而可以被动移动多少次呢?由该数后面有几个比他小的数决定[因为比他小的数都是要移动到他前面去的],所以树状数组倒着扫描,计算一个数后面有多少个比这个数小的数。

代码

#include<bits/stdc++.h>
using namespace std;

int a[100005];
int c[100005];
int n=100005;
int ans[100005];
int bits(int k)
{
    return k&-k;
}

int sum(int k)
{
    int ans=0;
    while(k>0)
    {
        ans+=c[k];
        k-=bits(k);
    }
    return ans;
}
int add(int k,int val)
{
    while(k<=n)
    {
        c[k]+=val;
        k+=bits(k);
    }
}

int main()
{
    int jj;
    scanf("%d",&jj);
    int k=0;

    while(jj--)
    {   memset(a,0,sizeof(a));
        memset(c,0,sizeof(c));
        memset(ans,0,sizeof(ans));
        k++;
        int z;
        scanf("%d",&z);
        for(int i=1;i<=z;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=z;i>=1;i--)
        {   int t=sum(a[i]);
            add(a[i],1);

            int rimost=i+t;
            int lemost=min(a[i],i);
            ans[a[i]]=rimost-lemost;
        }
        printf("Case #%d:",k);
        for(int i=1;i<=z;i++)
            printf(" %d",ans[i]);
        printf("\n");
    }
    return 0;
}

体会

长姿势了,树状数组并不仅仅局限在正序扫描数组,主要根据自己要处理的数据而定,用树状数组的特性是 [1.要对一段数做求和处理 2.更改其中某个数以后,可以快速更新整段的和]

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值