HDU 5187 zhx's contest (解决LL*LL%mod)(mod为LL型)

http://acm.hdu.edu.cn/showproblem.php?pid=5187

zhx's contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3138    Accepted Submission(s): 1015


Problem Description
As one of the most powerful brushes, zhx is required to give his juniors n problems.
zhx thinks the ith problem's difficulty is i . He wants to arrange these problems in a beautiful way.
zhx defines a sequence {ai} beautiful if there is an i that matches two rules below:
1: a1..ai are monotone decreasing or monotone increasing.
2: ai..an are monotone decreasing or monotone increasing.
He wants you to tell him that how many permutations of problems are there if the sequence of the problems' difficulty is beautiful.
zhx knows that the answer may be very huge, and you only need to tell him the answer module p .
 

Input
Multiply test cases(less than 1000 ). Seek EOF as the end of the file.
For each case, there are two integers n and p separated by a space in a line. ( 1n,p1018 )
 

Output
For each test case, output a single line indicating the answer.
 

Sample Input
  
  
2 233 3 5
 

Sample Output
  
  
2 1
Hint
In the first case, both sequence {1, 2} and {2, 1} are legal. In the second case, sequence {1, 2, 3}, {1, 3, 2}, {2, 1, 3}, {2, 3, 1}, {3, 1, 2}, {3, 2, 1} are legal, so the answer is 6 mod 5 = 1
题意:一列数字(1到n随机排列)最多出现一次转折点(由降转升,或者是由升转降)的方案数有多少

思路:一个是打表找规律,会发现是((((0*2+2)*2+2)*2+2)*2+2)*2+2,矩阵快速幂可以解决

总结后就是2^n-2;可以用快速幂解决;

http://blog.csdn.net/mengxiang000000/article/details/70208498看了博客,我才知道(解决LL*LL%mod的方法)(mod为LL型)


矩阵快速幂:

#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string>
#include<string.h>
#include<algorithm>
#define LL long long
using namespace std;
LL mod;
struct node
{
    LL m[3][3];
    void mem()
    {
        memset(m,0,sizeof(m));
    }
};
LL kuaisucheng(LL a,LL b)//LL *LL %mod不爆的快速乘法(这个感觉跟快速幂的道理是一样的)
{
    LL ans=0;
    while(b)
    {
        if(b&1)
        {
            ans+=a;
            if(ans>=mod) ans%=mod;
        }
        a=a*2;
        if(a>=mod) a%=mod;
        b/=2;
    }
    return ans;// a * b % mod
}
node operator *(node a,node b)
{
    node c;
    c.mem();
    for(int i=0; i<2; i++)
        for(int j=0; j<2; j++)
            for(int k=0; k<2; k++)
            {
                c.m[i][j]+=kuaisucheng(a.m[i][k],b.m[k][j])%mod;
                if(c.m[i][j]>=mod) c.m[i][j]%=mod;
            }
    return c;
}
LL pow(LL n)
{
    node a,b;
    a.mem(),b.mem();
    a.m[0][0]=2;
    a.m[1][0]=1,a.m[1][1]=1;
    b.m[0][1]=2;
    while(n)
    {
        if(n&1) b=b*a;
        a=a*a;
        n/=2;
    }
    return b.m[0][0];
}
int main()
{
    LL n;
    while(~scanf("%lld%lld",&n,&mod))
    {
        printf("%lld\n",pow(n-1));
    }
}


2^n-2   :快速幂
#include<stdio.h>
#include<string.h>
using namespace std;
#define ll __int64
ll kuaisucheng(ll a,ll b,ll mod)
{
    ll ans=0;
    while(b)
    {
        if(b&1)
        {
            ans=(ans+a);
            if(ans>=mod)ans-=mod;
        }
        a=(a+a);
        if(a>=mod)a-=mod;
        b/=2;
    }
    return ans;
}
ll kuaisumi(ll a,ll b,ll mod)
{
        a%=mod;
        ll ans=1;
        while(b)
        {
            if(b&1)
            {
                ans=kuaisucheng(ans,a,mod);
            }
            a=kuaisucheng(a,a,mod);
            b/=2;
        }
        return ans;
}
int main()
{
    ll n,mod;
    while(~scanf("%I64d%I64d",&n,&mod))
    {
        printf("%I64d\n",(kuaisumi(2,n,mod)-2+mod)%mod);
    }
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值