HDU-FatMouse' Trade

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 86758    Accepted Submission(s): 30125


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
 
 
5 3
7 2
5 2
4 3
25 18
20 3
15 10
24 15
-1 -1
 
Sample Output
 
 
13.333
31.500
  题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1009
题意大致就是:一个老鼠手里面有M磅的猫食,想拿猫食和看守粮仓的猫换取Javabean(老鼠的食物),一共有N个仓库每个仓库里都有一定量的Javabean(J[I]),每一定量的Javabean都要拿一定量的catfood(f[i)来换,即老鼠要拿j[i]*a%就要拿f[i]*a%来换,问老鼠最多能拿多少Javabean?
刚学完贪心算法里面的背包问题决定写写博客巩固一下。当然第一次写博客有不对的地方欢迎大佬批评指正。
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>

using namespace std;
struct bean{
double j;
double f;
double d;
}a[10005];
bool cmp1(bean a,bean b){
if(a.d>b.d) return true; /*按bean的性价比排序,性价比越高说明拿到的就越多。 
之前这道题我是按Javabean的数量排序,结果第二组样例没过 。后来仔细想想按
Javabean和catfood的性价比排序,因为如果按之前的方式排序如果你开始拿到的Javabean
较多但同时你支付的catfood就不一定少了,所以按性价比排序可以保证拿到的Javabean
较多同时catfood支付也相对合适*/ 

return false;
}
int main(){
int M,N;
while(scanf("%d %d",&M,&N)!=EOF){
if(M==-1&&N==-1) break;
for(int i=0;i<N;i++){
scanf("%lf %lf",&a[i].j,&a[i].f);
a[i].d=a[i].j/a[i].f;
}
sort(a,a+N,cmp1);
double sum=0;
double cleft=M;
//这道题的贪心 
for(int i=0;i<N;i++){
if(cleft<=a[i].f) { //先判断自己手中的catfood够不够换完 
sum=sum+cleft*a[i].d; //注意要用自己手中的catfood*性价比 
break;
}
else{
sum=sum+a[i].j;
cleft=cleft-a[i].f;
}
if(cleft<=0) break;
}
printf("%.3lf\n",sum);
}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值