poj3278——Catch That Cow【BFS】

Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 117541 Accepted: 36698

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver

[Submit]   [Go Back]   [Status]   [Discuss]

题目大意:在一条x轴上从n点到k点可以有x-1,x+1,2*x种方式,每种方式要1分钟,问到达k点做少需要多长时间 。

BFS模版题,直接枚举3种走法即可。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
const int MAXN=1e6+5;
int n,k;
bool vis[MAXN];
struct node{
    int x,step;
    bool friend operator <(node a,node b){
        return a.step>b.step;
    }
};
void BFS(){
    memset(vis,0,sizeof(vis));
    priority_queue<node> qu;
    node e1;
    e1.x=n,e1.step=0;
    vis[e1.x]=1;
    qu.push(e1);
    int ans=0;
    while(!qu.empty()){
        e1=qu.top();qu.pop();
        if(e1.x==k){
            ans=e1.step;
            break;
        }
        int pos=0;
        pos=e1.x-1;
        if(pos<=MAXN&&!vis[pos]&&pos>0){
            node e2;
            e2.x=pos;
            e2.step=e1.step+1;
            vis[pos]=1;
            qu.push(e2);
        }
        pos=e1.x+1;
        if(pos<=MAXN&&!vis[pos]&&pos>0){
            node e2;
            e2.x=pos;
            e2.step=e1.step+1;
            vis[pos]=1;
            qu.push(e2);
        }
        pos=e1.x*2;
        if(pos<=MAXN&&!vis[pos]&&pos>0){
            node e2;
            e2.x=pos;
            e2.step=e1.step+1;
            vis[pos]=1;
            qu.push(e2);
        }
    }
    printf("%d\n",ans);
}
int main(){
    while(~scanf("%d%d",&n,&k)){
        if(n>=k) printf("%d\n",n-k);
        else BFS();
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值