HDU - 1372 ——Knight Moves【BFS】

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy. 
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. 

Input

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. 

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.". 

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

题目大意:在国际象棋中,骑士从一个店到另一个点最少需要多少步,这道题之前WA了很多次,主要是不知道国际象棋里骑士的走法和象棋里马走日的走法相同,这里主要是改变一下方向数组就可以了。

#include<algorithm>
#include<cstdio>
#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
int sx,sy,ex,ey,ans;
bool vis[50][50];
struct node{
    int x,y,step;
    bool friend operator <(node a,node b){
        return a.step>b.step;
    }
};
int dx[8]={-2,-2,-1,1,1,-1,2,2},dy[8]={-1,1,-2,2,-2,2,-1,1};
void BFS(){
    priority_queue<node> qu;
    node e1;
    e1.x=sx,e1.y=sy,e1.step=0;
    vis[sx][sy]=1;
    qu.push(e1);
    while(!qu.empty()){
        e1=qu.top();qu.pop();
        node e2;
        if(e1.x==ex&&e1.y==ey){
            ans=e1.step;
            break;
        }
        for(int i=0;i<8;i++){
            e2.x=e1.x+dx[i];
            e2.y=e1.y+dy[i];
            if(e2.x>=1&&e2.x<=8&&e2.y>=1&&e2.y<=8&&!vis[e2.x][e2.y]){
                vis[e2.x][e2.y]=1;
                e2.step=e1.step+1;
                qu.push(e2);
            }
        }
    }
}
int main(){
    char s1[3],s2[3];
    while(~scanf("%s%s",s1,s2)){
        getchar();
        ans=-1;
        memset(vis,0,sizeof(vis));
        sy=s1[0]-'a'+1;
        sx=s1[1]-'0';
        ey=s2[0]-'a'+1;
        ex=s2[1]-'0';
       // printf("%d %d %d %d\n",sx,sy,ex,ey);
        BFS();
        printf("To get from %s to %s takes %d knight moves.\n",s1,s2,ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
回答: 引用\[1\]和引用\[2\]是关于解决HDU - 3853问题的AC代码。这段代码使用了动态规划的思路,通过计算每个点的期望能量来解决问题。其中,f\[i\]\[j\]表示走到(i, j)这个点的期望能量。代码中还有一些特殊情况的处理,比如停留在原地的花费为2点,停留在原地的概率为1的情况下期望能量为0。\[1\]\[2\] 引用\[3\]是关于Akemi Homura的描述,她是一个魔法少女,想要帮助她的朋友Madoka拯救世界。但由于Boss孵化器的情节,她被困在一个叫做LOOPS的迷宫中。\[3\] 所以,问题A - LOOPS HDU - 3853是关于解决迷宫问题的一个题目。 #### 引用[.reference_title] - *1* *3* [期望DP——C - LOOPS HDU - 3853](https://blog.csdn.net/GreyBtfly/article/details/80534173)[target=&quot;_blank&quot; data-report-click={&quot;spm&quot;:&quot;1018.2226.3001.9630&quot;,&quot;extra&quot;:{&quot;utm_source&quot;:&quot;vip_chatgpt_common_search_pc_result&quot;,&quot;utm_medium&quot;:&quot;distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt&quot;}} ] [.reference_item] - *2* [HDU 3853-LOOPS【期望DP】](https://blog.csdn.net/qq_41785863/article/details/102570840)[target=&quot;_blank&quot; data-report-click={&quot;spm&quot;:&quot;1018.2226.3001.9630&quot;,&quot;extra&quot;:{&quot;utm_source&quot;:&quot;vip_chatgpt_common_search_pc_result&quot;,&quot;utm_medium&quot;:&quot;distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt&quot;}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值