CRB and His Birthday

CRB and His Birthday

Time Limit: 1000ms
Memory Limit: 65536KB
64-bit integer IO format: %I64d      Java class name: Main

Today is CRB's birthday. His mom decided to buy many presents for her lovely son.
She went to the nearest shop with $M$ Won(currency unit).
At the shop, there are $N$ kinds of presents.
It costs $W_{i}$ Won to buy one present of $i$-th kind. (So it costs $k$ × $W_{i}$ Won to buy $k$ of them.)
But as the counter of the shop is her friend, the counter will give $A_{i}\ ×\ x\ +\ B_{i}$ candies if she buys $x$($x$>0) presents of $i$-th kind.
She wants to receive maximum candies. Your task is to help her.
1 ≤ $T$ ≤ 20
1 ≤ $M$ ≤ 2000
1 ≤ $N$ ≤ 1000
0 ≤ $A_{i},\ B_{i}$ ≤ 2000
1 ≤ $W_{i}$ ≤ 2000

Input

There are multiple test cases. The first line of input contains an integer $T$, indicating the number of test cases. For each test case:
The first line contains two integers $M$ and $N$.
Then $N$ lines follow, $i$-th line contains three space separated integers $W_{i}$, $A_{i}$ and $B_{i}$.

Output

For each test case, output the maximum candies she can gain.

Sample Input

1
100 2
10 2 1
20 1 1

Sample Output

21

题解:先用01背包跑一遍A[i]+B[i]的,再用完全背包跑一遍A[i]……


#include<cstdio>
#include<cmath>
#include<string>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<queue>
#include<stack>
#include<ctime>
using namespace std;
int dp[2005],a[2005],b[2005],w[2005];
int main()
{
    int t,n,m;
     scanf("%d",&t);
     while(t--)
     {
         scanf("%d%d",&m,&n);
         for(int i=1;i<=n;i++)
            scanf("%d%d%d",&w[i],&a[i],&b[i]);
        memset(dp,0,sizeof(dp));
         for(int i=1;i<=n;i++)
         {
             for(int j=m;j>=w[i];j--)
                dp[j]=max(dp[j],dp[j-w[i]]+a[i]+b[i]);
             for(int j=w[i];j<=m;j++)
                dp[j]=max(dp[j],dp[j-w[i]]+a[i]);
         }
         printf("%d\n",dp[m]);
     }
}












  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值