CRB and His Birthday(HDU-5410)

12 篇文章 1 订阅
4 篇文章 0 订阅
Problem Description
Today is CRB's birthday. His mom decided to buy many presents for her lovely son.
She went to the nearest shop with M Won(currency unit).
At the shop, there are N kinds of presents.
It costs Wi Won to buy one present of i -th kind. (So it costs k × Wi Won to buy k of them.)
But as the counter of the shop is her friend, the counter will give Ai × x + Bi candies if she buys x ( x >0) presents of i -th kind.
She wants to receive maximum candies. Your task is to help her.
1 ≤ T ≤ 20
1 ≤ M ≤ 2000
1 ≤ N ≤ 1000
0 ≤ Ai, Bi ≤ 2000
1 ≤ Wi ≤ 2000
 

Input
There are multiple test cases. The first line of input contains an integer T , indicating the number of test cases. For each test case:
The first line contains two integers M and N .
Then N lines follow, i -th line contains three space separated integers Wi , Ai and Bi .
 

Output
For each test case, output the maximum candies she can gain.
 

Sample Input
  
  
1 100 2 10 2 1 20 1 1
 

Sample Output
  
  
21
Hint
CRB's mom buys 10 presents of first kind, and receives 2 × 10 + 1 = 21 candies.
 

题意:给定背包容量m,物品种类n,每种物品的重量a[i],还有卖的数量x对应的价值b[i]*x+c[i],求最大的价值。

思路:先做一遍完全背包,把c[i]加上去,再用01背包选择拿哪些;

#include <iostream>
#include<cstdio>
#include<cstring>
#include <algorithm>
using namespace std;
int a[1005],b[1005],c[1005];
int dp[2005];
int t,m,n;
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&m,&n);
        memset(dp,0,sizeof(dp));
        for(int i=0; i<n; i++)
        {
            scanf("%d%d%d",&a[i],&b[i],&c[i]);
        }
        int ans=0;
        for(int i=0; i<n; i++)
        {
            for(int j=a[i]; j<=m; j++)  //完全背包
            {
                dp[j]=max(dp[j],dp[j-a[i]]+b[i]);
                ans=max(ans,dp[j]);
            }
            for(int j=m; j>=a[i]; j--)  //01背包
            {
                dp[j]=max(dp[j],dp[j-a[i]]+b[i]+c[i]);
                ans=max(ans,dp[j]);
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值