《动态规划》— HDU 5410 CRB and His Birthday(01背包+完全背包)

CRB and His Birthday

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2042    Accepted Submission(s): 962

 

 

Problem Description

Today is CRB's birthday. His mom decided to buy many presents for her lovely son.
She went to the nearest shop with M Won(currency unit).
At the shop, there are N kinds of presents.
It costs Wi Won to buy one present of i-th kind. (So it costs k × Wi Won to buy k of them.)
But as the counter of the shop is her friend, the counter will give Ai × x + Bi candies if she buys x(x>0) presents of i-th kind.
She wants to receive maximum candies. Your task is to help her.
1 ≤ T ≤ 20
1 ≤ M ≤ 2000
1 ≤ N ≤ 1000
0 ≤ Ai, Bi ≤ 2000
1 ≤ Wi ≤ 2000

 

 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains two integers M and N.
Then N lines follow, i-th line contains three space separated integers Wi, Ai and Bi.

 

 

Output

For each test case, output the maximum candies she can gain.

 

 

Sample Input

 

1 100 2 10 2 1 20 1 1

 

 

Sample Output

 

21

Hint

CRB's mom buys 10 presents of first kind, and receives 2 × 10 + 1 = 21 candies.

 

 

Author

KUT(DPRK)

 

 

Source

2015 Multi-University Training Contest 10

值得借鉴

 

//题意:有M元钱,N种物品,每种物品的单价为W[i],如果都买第i件商品K件,则需要花费W[i]*K元钱,同时会获得A[i]*K+B[i]个糖果,问可以获得的最大糖果数量。
//思路:先来一遍01背包,价值看成是A[i]+B[i],再来一遍完全背包,价值看成是A[i]即可。
#include<stdio.h>
#include<string.h>
#include<string.h>
#include<stack>
#include<queue>
#include<math.h>
#include<algorithm>

using namespace std;
const int maxn = 1005;

int W[maxn];
int A[maxn];
int B[maxn]; 
int DP[maxn*2];
int M,N;
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&M,&N);
		
		//初始化
		memset(W,0,sizeof(W));
		memset(A,0,sizeof(A));
		memset(B,0,sizeof(B));
		memset(DP,0,sizeof(DP));
		
		for(int i = 1; i <= N; i++)
		{
			scanf("%d%d%d",&W[i],&A[i],&B[i]);
		} 
		
		for(int i = 1; i <= N; i++)
		{
			for(int j = M; j >= W[i]; j--)
			{
				DP[j] = max(DP[j],DP[j-W[i]]+A[i]+B[i]);//01背包决定取不取
			}
			for(int j = W[i]; j <= M; j++)
			{
				DP[j] = max(DP[j],DP[j-W[i]]+A[i]); //完全背包决定取最大价值
			}
		}
		printf("%d\n",DP[M]);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值