AC Challenge(状压dp)

Dlsj is competing in a contest with n(0<n≤20)n (0 < n \le 20)n(0<n≤20) problems. And he knows the answer of all of these problems.

However, he can submit iii-th problem if and only if he has submitted (and passed, of course) sis_isi​ problems, the pi,1p_{i, 1}pi,1​-th, pi,2p_{i, 2}pi,2​-th, ........., pi,sip_{i, s_i}pi,si​​-th problem before.(0<pi,j≤n,0<j≤si,0<i≤n)(0 < p_{i, j} \le n,0 < j \le s_i,0 < i \le n)(0<pi,j​≤n,0<j≤si​,0<i≤n) After the submit of a problem, he has to wait for one minute, or cooling down time to submit another problem. As soon as the cooling down phase ended, he will submit his solution (and get "Accepted" of course) for the next problem he selected to solve or he will say that the contest is too easy and leave the arena.

"I wonder if I can leave the contest arena when the problems are too easy for me."
"No problem."
—— CCF NOI Problem set

If he submits and passes the iii-th problem on ttt-th minute(or the ttt-th problem he solve is problem iii), he can get t×ai+bit \times a_i + b_it×ai​+bi​ points. (∣ai∣,∣bi∣≤109)(|a_i|, |b_i| \le 10^9)(∣ai​∣,∣bi​∣≤109).

Your task is to calculate the maximum number of points he can get in the contest.

Input

The first line of input contains an integer, nnn, which is the number of problems.

Then follows nnn lines, the iii-th line contains si+3s_i + 3si​+3 integers, ai,bi,si,p1,p2,...,psia_i,b_i,s_i,p_1,p_2,...,p_{s_i}ai​,bi​,si​,p1​,p2​,...,psi​​as described in the description above.

Output

Output one line with one integer, the maximum number of points he can get in the contest.

Hint

In the first sample.

On the first minute, Dlsj submitted the first problem, and get 1×5+6=111 \times 5 + 6 = 111×5+6=11 points.

On the second minute, Dlsj submitted the second problem, and get 2×4+5=132 \times 4 + 5 = 132×4+5=13 points.

On the third minute, Dlsj submitted the third problem, and get 3×3+4=133 \times 3 + 4 = 133×3+4=13 points.

On the forth minute, Dlsj submitted the forth problem, and get 4×2+3=114 \times 2 + 3 = 114×2+3=11 points.

On the fifth minute, Dlsj submitted the fifth problem, and get 5×1+2=75 \times 1 + 2 = 75×1+2=7 points.

So he can get 11+13+13+11+7=5511+13+13+11+7=5511+13+13+11+7=55 points in total.

In the second sample, you should note that he doesn't have to solve all the problems.

样例输入1

5
5 6 0
4 5 1 1
3 4 1 2
2 3 1 3
1 2 1 4

样例输出1

55

样例输入2

1
-100 0 0

样例输出2

0

题目来源

ACM-ICPC 2018 南京赛区网络预赛

思路:状压dp。

由于不熟练,写的蛮久的。

思路就是因为最多20门课程,所以将所有情况都枚举一遍进行暴力。思路就是每一次都枚举一遍最后做的作业是哪个,看一下情况是否合法。而且初值要弄成-inf,这样假设一个价值超大的作业,但是前边完成的铺垫是负数,这样加起来是最大的,这样才OK。

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=100;
const int INF=0x3f3f3f3f;
int dp[1<<20];
long long ans;
int a[30],b[30];
int c[1<<20];
int main()
{
    ans=-INF;
    for(int i=0;i<(1<<20);i++){
        dp[i]=-INF;
    }
    int n,numm,x;
    scanf("%d",&n);
    dp[0]=0;
    for(int i=1;i<=n;i++){
        scanf("%d%d%d",&a[i],&b[i],&numm);
        c[i]=0;
        for(int j=0;j<numm;j++){
            scanf("%d",&x);
            c[i]=(c[i]|(1<<(x-1)));
        }
    }
    int flag,temp,lala;
    int haha=0;
    for(int i=0;i<(1<<n);i++)///把所有情况枚举一遍
    {
        for(int j=1;j<=n;j++){
            lala=(1<<(j-1));///lala代表当前枚举的最后一位是谁.选第j门课
            if(i&(1<<(j-1)))///当前状态中有第j门课,才进行判断
            {
                int xpp=lala^(i);///表示没学这门课的状态
                if(dp[xpp]==-INF)///如果这种状态不存在,或者还未更新
                    continue;
                if( (i|c[j])==i )///就是状态 i 中,c[j]有的,i 中都有
                {
                    int haha=i;
                    int time=0;
                    while(haha){
                        if(haha%2==1)
                            time++;
                            haha=haha/2;
                    }
                    dp[i]=max(dp[i],dp[xpp]+a[j]*time+b[j]);///
                    ans=max(ans,(long long)dp[i]);
                }
            }
        }
    }
   /// cout<<"haha:"<<haha<<endl;
    printf("%lld\n",ans);
}
/*
5
5 6 0
4 5 1 1
3 4 1 2
2 3 1 3
1 2 1 4
*/


 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值