PAT A1077

3 篇文章 0 订阅
  • 题目:
    The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

    Itai nyan~ (It hurts, nyan~)

    Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?
Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.
Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.
Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

  • 解题思路
    将字符串逆转,从头开始判断有多少个字符相同,若相同,则将字符压入res容器。
    需要解决的问题:
    1.如何将字符串逆转
for(int i =0; i <size/2; i++){
            int temp = str[i];
            str[i] = str[size-i-1];
            str[size-i-1] = temp;
        }

2.如何读取含有空格的字符串
参考:https://blog.csdn.net/Mrx_Nh/article/details/79716445#commentBox
在处理输入的时候,有时需要输入一整行字符串,而字符串中包含类似空格,tab这样的特殊符号,直接用cin读入时不能得到预期效果,这里介绍一下C++中的整行字符串读入方法。

istream& getline (istream&  is, string& str, char delim);
istream& getline (istream&& is, string& str, char delim);
istream& getline (istream&  is, string& str);
istream& getline (istream&& is, string& str);

注意:delim是结束标志符号,缺省值为’\n’即换行符。

代码实现:

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main()
{
    int n, min_size = 257;
    vector<string> st;
    vector<char> res;
    cin >> n;
    cin.get();              //读入换行符,避免getline直接退出(默认为换行符算一次读入)
    for(int i = 0; i < n; i++){
        string str;
        getline(cin,str);
        int size = str.size();
        for(int i =0; i <size/2; i++){                  //反转字符串
            int temp = str[i];
            str[i] = str[size-i-1];
            str[size-i-1] = temp;
        }
        st.push_back(str);
        if(min_size > st[i].size())
            min_size = st[i].size();
    }
    for(int i =0; i < min_size; i++){
        char c =st[0][i];
        bool tag = true;
        for(int j = 1; j< n; j++){
            if(c != st[j][i])
             {
                 tag = false;
                 break;
             }
        }
        if(tag){
            res.push_back(c);
        }
        else
            break;
    }
    if(res.size() == 0)
        cout << "nai";
    else
       for(int i = res.size()-1; i>=0; i--)
        cout << res[i];
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值