PAT A1047

  • 题目:
    Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.
    Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.
Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.
Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

  • 解题思路
    1.以二维数组 char[N][5]存放输入的姓名,其中char[i]表示第i个姓名
    以vector数组course[]存放选没门课的学生编号,其中course[i]存放所有选第i门课的学生编号
    2.在读入数据时,若某个学生i选择了课程j,则将i存放到coures[j]
    3.对每一门课i,将course[i]中的学生按照姓名字典序从小到大排序,然年输出所要的结果

代码实现:

#include <cstring>
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn = 40010;
const int maxc = 20010;
char name[maxn][5];                            //name存放学生姓名
vector<int > course[maxc];                 //course[i]存放第i门课的所有学生编号
bool cmp(int a, int b){
    return strcmp(name[a], name[b]) < 0;             //按照字母顺序排序
}
int main()
{
    int n, k, c, temp;
    scanf("%d%d",&n, &k );
    for(int i = 0; i < n; i++){
        scanf("%s %d", name[i],&c);
        for(int j = 0; j < c; j++){
            scanf("%d", &temp);
            course[temp].push_back(i);                //将学生i加入第courseID门课中
        }
    }
    for(int i = 1; i <= k; i++){
        printf("%d %d\n", i,course[i].size());
        sort(course[i].begin(), course[i].end(), cmp);                       //对第i门课学生排序
        for(int j = 0; j < course[i].size(); j++)
            printf("%s\n", name[course[i][j]]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值