1018 Public Bike Management Java 学习笔记


题目

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

Figure 1
Figure 1 illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:

PBMC -> S1 -> S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1 and then take 5 bikes to S3, so that both stations will be in perfect conditions.

PBMC -> S2 -> S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax (<= 100), always an even number, is the maximum capacity of each station; N (<= 500), the total number of stations; Sp, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci (i=1,…N) where each Ci is the current number of bikes at Si respectively. Then M lines follow, each contains 3 numbers: Si, Sj, and Tij which describe the time Tij taken to move betwen stations Si and Sj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0->S1->…->Sp. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Sp is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.

Sample Input:
10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1
Sample Output:
3 0->2->3 0
5026

代码

import java.util.ArrayList;
import java.util.Scanner;

class Main{
	static Scanner sc=new Scanner(System.in);
	static int cMax=sc.nextInt();//站点最大容量
	static int n=sc.nextInt(); //总站点个数
	static int Sp=sc.nextInt();//问题站点
	static int m=sc.nextInt();//道路数
	static int [][]map=new int [n+1][n+1];//存储路径,因为PBMC不算入站点数,所有+1
	static int bikes[]=new int [n+1];//站点自行车数量
	static int dist[]=new int [n+1];
	static ArrayList[] pre=new ArrayList[n+1];//用于记录最短路径,每个站点的前一个站点
	static boolean []visit=new boolean[n+1];
	static int need[];
	static int back[];
    public static void main(String[] args) {
    	dist[0]=0;
    	for(int i=1;i<=n;i++) {
    		bikes[i]=sc.nextInt();
    		dist[i]=Integer.MAX_VALUE;
    	}
    	for(int i=0;i<=n;i++) {
    		for(int j=0;j<=n;j++) {
    			if(i!=j) map[i][j]=Integer.MAX_VALUE;//此路不通
    		}
    	}
    	for(int i=0;i<m;i++) {
    		int x=sc.nextInt();
    		int y=sc.nextInt();
    		map[x][y]=map[y][x]=sc.nextInt();
    	}
    	
    	//使用Dijsktra算法得出距离各站点距离最近的前一个站点
    	Dijsktra();
    	
    	//获取最短路径
    	ArrayList<Integer> path=new ArrayList<Integer>();//用于暂时存放路径
    	ArrayList<ArrayList<Integer>> list=new ArrayList<ArrayList<Integer>>();//用于存放多条最短路径
    	DFS(0,Sp,path,list);
    	
    	//开始计算各条路径所需自行车数
    	int ways=list.size();//最短路径数量
    	need=new int[ways];//需要的自行车数量
    	back=new int[ways];//返回的自行车数量
    	for (int k = 0; k < ways; k++) {
			Getnum(k, list.get(k));
			//System.out.println(need[k]+" "+back[k]);
		}
    	
    	//获取符合题目的唯一路径数
    	int num=compare(ways);
    	
    	//输出结果
    	ArrayList<Integer> res=list.get(num);
    	System.out.print(need[num]+" ");
    	System.out.print(res.get(res.size()-1));
    	for (int i = res.size() - 2; i >= 0; i--) {
			System.out.print("->" + res.get(i));
		}
    	System.out.print(" "+back[num]);
    }
    //用来比较所需的自行车数量,保证输出的路径唯一,采用所需数量最少优先,返回数量其次的比较原则
    public static int compare(int ways) {
    	int num=0;
    	int min=need[0];
    	for(int i=1;i<ways;i++) {
    		if(need[i]<min) {
    			num=i;
    			min=need[i];
    		}
    		if(need[i]==min&&back[i]<back[num]) {
    			num=i;
    		}
    	}
    	return num;
    }
    public static void Dijsktra() {
    	for(int i=0;i<=n;i++) {
    		int index=-1;
    		int min = Integer.MAX_VALUE;
    		for(int k=0;k<n;k++) {
    			if(!visit[k]&&min>dist[k]) {//查找未访问的城市中路径权值最小的城市
    				index=k;
    				min=dist[k];
    			}
    		}
    		if(index==-1) break;//说明所有可以通过的城市都已经访问完毕
    		visit[index]=true;//将目标城市设置成已访问
    		for(int j=0;j<=n;j++) {
    			if(!visit[j]&&map[index][j]!=Integer.MAX_VALUE) {
    				if(pre[j]==null) pre[j]=new ArrayList<Integer>();
    				if(dist[index]+map[index][j]<dist[j]) {
    					dist[j]=dist[index]+map[index][j];
    					pre[j].clear();
    					pre[j].add(index);
    				}else {
    					pre[j].add(index);
    				}
    			}
    		}
    	}
    }
    //本函数使用DFS算法求出所有的最短路径并记录在list中,从问题站开始遍历到起点处停止
    public static void DFS(int S,int Sp,ArrayList<Integer> path,ArrayList<ArrayList<Integer>>list) {
		if(S==Sp) {//如果退到了起点处
			path.add(Sp);//记录当前站点
			list.add(new ArrayList<Integer>(path));//记录当前的路线
			path.remove(path.size()-1);//删除最后一个站点,以记录新路线
			return;
		}
		ArrayList<Integer> Sta=pre[Sp];
		for(int a:Sta) {//遍历当前站点的前一个站点
			path.add(Sp);
			DFS(S, a, path, list);
			path.remove(path.size()-1);
		}
	}
    //本函数用来计算出去与返回的自行车数量
    public static void Getnum(int k,ArrayList<Integer> path) {
    	int cur=0;
    	for(int i=path.size()-2;i>=0;i--) {//从起点站的下一个站开始计算,一直到问题站
    		if(bikes[path.get(i)]+cur<cMax/2) {//如果少于一半,则需要向总站借
    			need[k]+=cMax/2-(bikes[path.get(i)]+cur);
    			cur=0;
    		}else {
    			cur+=bikes[path.get(i)]-cMax/2;
    		}
    		if(i==0) back[k]=cur;
    	}
    	return;
    }
}

运行结果

在这里插入图片描述
不知道为什么错了一个,写了好久,暂时没心情改了,哪个大哥看出来原因了请d我一下!!!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值