1003 Emergency (25 分) java 学习记录

1003 Emergency (25 分) java 学习记录


源代码学习地址:https://blog.csdn.net/q982151756/article/details/78607619?spm=1001.2101.3001.6650.1&utm_medium=distribute.pc_relevant.none-task-blog-2%7Edefault%7ECTRLIST%7ERate-1-78607619-blog-114396285.pc_relevant_recovery_v2&depth_1-utm_source=distribute.pc_relevant.none-task-blog-2%7Edefault%7ECTRLIST%7ERate-1-78607619-blog-114396285.pc_relevant_recovery_v2&utm_relevant_index=2

题目

`
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4

解题思路

本题使用Dijkstra算法,在原有算法基础上本题需要另外记录最短路径数目以及最大的救援队伍数量。

代码

import java.util.Scanner;
class Main{
	
    public static void main(String[] args) {
    	Scanner sc=new Scanner(System.in);
    	int n=sc.nextInt();//城市数
    	int m=sc.nextInt();//道路数
    	int c1=sc.nextInt();//起点
    	int c2=sc.nextInt();//终点
    	int num[] = new int[n];//该城市救援队伍数
    	for(int i=0;i<n;i++) {
    		num[i]=sc.nextInt();
    	}
    	int edge[][]=new int [n][n];//道路权值
    	for(int i=0;i<n;i++) {
    		for (int j = 0; j < n; j++) {
				if(i!=j) {
					edge[i][j]=Integer.MAX_VALUE;//此路不通
				}else {
					edge[i][j]=0;
				}
			}
    	}
    	for(int i=0;i<m;i++) {
    		int a =sc.nextInt();
    		int b =sc.nextInt();
    		edge[a][b]=edge[b][a]=sc.nextInt();
    	}
    	boolean visit[]= new boolean[n];//城市是否被使用
    	int dist[]=new int[n];//最短路径权值
    	for(int i=0;i<n;i++) {
    		dist[i]=Integer.MAX_VALUE;
    	}
    	int team[]=new int[n];//最短路径救援队伍数量
    	int way[]=new int[n];//最短路径条数
    	
    	//开始使用dijistra算法进行计算
    	dist[c1]=0;//用于定位起点
    	team[c1]=num[c1];//给起点赋值
    	way[c1]=1;
    	
    	for(int i=0;i<n;i++) {
    		int index=-1;//定位目前所在城市
    		int min=Integer.MAX_VALUE;
    		for(int k=0;k<n;k++) {
    			if(!visit[k]&&min>dist[k]) {//查找未访问的城市中路径权值最小的城市
    				index=k;
    				min=dist[k];
    			}
    		}
    		if(index==-1) break;//说明所有可以通过的城市都已经访问完毕
    		visit[index]=true;//将目标城市设置成已访问
    		for (int j = 0; j < n; j++) {
    			if(!visit[j]&&edge[index][j]!=Integer.MAX_VALUE) {//如果城市未被访问且所在城市有道路可直接到达
    				if(dist[index]+edge[index][j]<dist[j]) {//如果j城市目前的最短路径大于从所在城市前往的路径则更新最短路径
    					dist[j]=dist[index]+edge[index][j];
    					team[j]=team[index]+num[j];//救援队伍增加
    					way[j]=way[index];
    				}else if (dist[index]+edge[index][j]==dist[j]) {//如果路径大小相等
    					if(team[j]<team[index]+num[j]) {//如果这条路径的救援队伍更多就更新
    						team[j]=team[index]+num[j];
    					}
    					way[j]+=way[index];//加上能到达index城市的道路数量
    				}   				
    			}
				
			}
    	}
    	System.out.print(way[c2]+" "+team[c2]);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值