PAT 甲级 1004 Counting Leaves (30 分)(Java)学习笔记

本文介绍了PAT甲级1004题——CountingLeaves的问题,这是一个关于树形结构和深度优先搜索(DFS)的编程题目。文章提供了Java解题代码,通过建立树的数据结构并使用DFS算法计算各层的叶子节点数量。
摘要由CSDN通过智能技术生成

PAT 甲级 1004 Counting Leaves (30 分)(Java)


学习源码网址:https://blog.csdn.net/weixin_45062103/article/details/105973102

题目

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:
2 1
01 1 02
Sample Output:
0 1

题意

  • 第一行输入两个值,N是这个树中的所有结点数,M是这个树里的非叶子结点数
  • 下面的M行是输入子树,ID是子树的根结点,K是根结点的孩子结点,随后输入K个结点
  • 输出的是树的每一层的叶子结点
  • 叶子结点指的是在这个结点下没有孩子结点

解题思路

使用DFS算法,使用数组leafnum记录各层的叶子节点数,每当DFS遇到叶子节点,则返回深度,该层叶子节点数加一。

代码

import java.util.HashMap;
import java.util.Scanner;

class Main{
	static Scanner sc=new Scanner(System.in);
	static int n =	sc.nextInt();//树中节点数
	static int m = sc.nextInt();//树中非叶子节点数
	static HashMap<Integer, int[]> tree=new HashMap<>();//用来存放树
	static int leafnum[]=new int [100];//索引为层数,存放叶子节点数
    public static void main(String[] args) {
    	for(int i=0;i<m;i++) {//建立树
    		int nodenum=sc.nextInt();
    		int k=sc.nextInt();
    		int nodes[]=new int [k];
    		for(int j=0;j<k;j++) {
    			nodes[j]=sc.nextInt();
    		}
    		tree.put(nodenum, nodes);
    	}
    	//使用DFS算法,迭代得出深度
    	int deep=DFS(01, 0);
    	//输出每层的叶子节点个数
    	for(int i=0;i<=deep;i++) {
    		if(i!=deep) {
    			System.out.print(leafnum[i]+" ");
    		}else {
    			System.out.println(leafnum[i]);
    		}
    	}
    	
    }
    public static int DFS(int node,int level) {
    	int deep=level;//树的深度
    	if(!tree.containsKey(node)) {//如果该节点没有子节点,即为叶子节点
    		leafnum[level]++;//该层叶子节点树加一
    		return deep;
    	}
    	int[] list=tree.get(node);//得到该节点的孩子节点数组
    	for(int i=0;i<list.length;i++) {
    		deep=Math.max(deep, DFS(list[i],level+1));//比较返回的子树深度与所记录的深度
    	}
		return deep;
    	
    }
}

运行结果

在这里插入图片描述

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值