PAT甲级1013 Battle Over Cities Java 学习笔记


题目

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题目大意

战争期间,城市被占领,则其城市所有的道路将被关闭。为了运送物资,将重新修建道路以保证各城市的联通,问要修建的道路数量。

思路

涉及到道路,所以本题使用图进行存储,考察的则是图的遍历。本题使用图的深度遍历DFS,对删除了被占据的城市节点的图进行遍历。一次迭代将遍历完一整个连通分量,当所有城市被访问后,所进行的迭代次数即为连通分量个数,而要修建的道路数量为连通分量个数减一。

代码

import java.util.Scanner;

class Main{
	static Scanner sc=new Scanner(System.in);
	static int n=sc.nextInt();//总城市个数
	static int m=sc.nextInt();//道路数
	static int k=sc.nextInt();//将被占领的城市个数
	static int [][]map=new int[n][n];//存放路径
    public static void main(String[] args) {
    	for(int i=0;i<m;i++) {//城市x,y间有路径
    		int x=sc.nextInt()-1;//因为城市从0开始,为了不溢出所以自动-1
    		int y=sc.nextInt()-1;
    		map[x][y]=map[y][x]=1;
    	}
    	for(int i=0;i<k;i++) {
    		int num=0;//图中删去被占领城市后的联通分量
    		boolean visit[]=new boolean[n];//初始化,将城市设置为未被访问或占据
    		int temp=sc.nextInt()-1;//被占领的城市
    		visit[temp]=true;//城市被占领
    		for(int j=0;j<n;j++) {
    			if(visit[j]==false) {//如果城市未被访问
    				DFS(j,visit);
    				num++;//连通分量加一
    			}
    		}
    		System.out.println(num-1);
    	}
    }
    public static void DFS(int city,boolean []visit) {
		visit[city]=true;//将可以访问到的城市设为已访问,一次可以遍历完一整个连通分量
		for (int i = 0; i < n; i++) {
			if(visit[i]==false&&map[city][i]==1) {//如果i城市未被访问且存在去往i城市的路径
				DFS(i,visit);
			}
		}
	}
}

运行结果在这里插入图片描述

总结

本题有一个测试点超时,在网上找了一圈没找到成功解决的java算法。如果有兄弟找到了,麻烦评论区d我一下。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值