Can you find it?

Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
Case 1:
NO
YES

NO

//把a,b两个数组合并起来,然后在c数组冲查找X-A-B这个数值。

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;
#define Max 505
int L,M,N;
__int64 a[Max],b[Max],c[Max];
__int64 ab[250005];
int num;
int S;
__int64 X;
bool find(__int64 x,int low,int high)
{
	int mid;
	while(low<=high)
	{
		mid=(low+high)/2;
		if(ab[mid]==x) return 1;
		if(ab[mid]>x) high=mid-1;
		else low=mid+1;
	}
	return 0;
}
int main()
{
	//freopen("b.txt","r",stdin);
	int cas=0;
	while(scanf("%d %d %d",&L,&N,&M)==3)
	{
		printf("Case %d:\n",++cas);
		int i,j;
		num=0;
		for(i=0;i<L;i++)
			scanf("%I64d",&a[i]);
		for(i=0;i<N;i++)
			scanf("%I64d",&b[i]);
		for(i=0;i<L;i++)
			for(j=0;j<N;j++)
				ab[num++]=a[i]+b[j];
			sort(ab,ab+num);
		for(i=0;i<M;i++)
			scanf("%I64d",&c[i]);
		sort(c,c+M);
		scanf("%d",&S);
		while(S--)
		{
			bool flag=0;
			scanf("%I64d",&X);
			if(ab[0]+c[0]>X||ab[num-1]+c[M-1]<X) {printf("NO\n");continue;}
			for(i=0;i<M&&!flag;i++)
			{
					if(find(X-c[i],0,num-1))
						flag=1;
			}
			if(flag) printf("YES\n");
			else printf("NO\n");
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值