HDU 2141 Can you find it?(二分)

117 篇文章 0 订阅
7 篇文章 0 订阅
Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".

Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

Sample Output
Case 1:
NO
YES

NO


题意:给你三个数组,再给你一些数,判断三个数组内是否有Ai+Bi+Ci==x.如果有输出YES,否则输出NO、
思路:先将前两个数组两两相加构成一个新数组,快排。然后新数组和第三个数组相加,二分,不断用中间的和第三个数组的元素相加,直到得x或者跳出循环为止。
代码:
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#define xps 1e-12
using namespace std;
int main()
{
	long long l,m,n,o=1;
	while(cin>>l>>m>>n)
	{
	long long a[510],b[510],c[510],d[250010];
	for(int i=0;i<l;i++)//输入三个数组 
	cin>>a[i];
	for(int i=0;i<m;i++)
	cin>>b[i];
	for(int i=0;i<n;i++)
	cin>>c[i];
	int k=0;
	for(int i=0;i<l;i++)
	for(int j=0;j<m;j++)
	d[k++]=a[i]+b[j];//前两个数组两两相加得到新数组 
	sort(d,d+k);//从小到大排序 
	int s;
	cin>>s;
	cout<<"Case "<<o++<<":"<<endl;//输出第几个测试实例 
	while(s--)
	{
		long long x;
		cin>>x;
		bool sign =false;
		for(int i=0;i<n;i++)//第三个数组和新数组mid相加判断 
		{
		int l=0,r=k-1;
		while(l<=r)
		{
			int mid=(l+r)>>1;
			if(d[mid]+c[i]==x)
			{
				sign=true;
				break;
			}
			else if(d[mid]+c[i]<x)
			{
				l=mid+1;
			}
			else
			r=mid-1;
		}	
		if(sign)
		break;
		}
		if(sign)
		cout<<"YES"<<endl;
		else
		cout<<"NO"<<endl;
	}	
	}
	return 0;
}


  • 3
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值