hdu1856(并查集)

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 9837    Accepted Submission(s): 3624


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 
本题要求图中最大连通分支的节点数,可以考虑搜索,但并查集更为方便,所以本题我用并查集,相当于依次合并a、b,然后求最大子集的个数,操作简单
#include<iostream>
#include<cstdio>
using namespace std;

const int MAX= 10000000+10;
int par[MAX];
int sum[MAX];


int Get_par(int a)
//查找a的父亲节点并压缩路径
{
	if(par[a]==a)
		return par[a];
	par[a]=Get_par(par[a]);
	return par[a];
}


void Merge(int a,int b)
//合并a,b
{
	int pa,pb;
	pa=Get_par(a);
	pb=Get_par(b);
	if(pa==pb)
		return ;
	if(sum[pa]>sum[pb])
		par[pb]=pa,sum[pa]+=sum[pb];
	else 
		par[pa]=pb,sum[pb]+=sum[pa];
}

int main()
{
	int a,b,i,n,ans;
	while(~scanf("%d",&n))
	{
		for(i=1;i<=MAX-1;i++)
		{
			par[i]=i,sum[i]=1;
		}

		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&a,&b);
			Merge(a,b);
		}

		//寻找最大子集
		ans=-1;
		for(i=1;i<=MAX-1;i++)
			if(sum[i]>ans)
				ans=sum[i];
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值