poj 2002 Square

3 篇文章 0 订阅
Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 18509 Accepted: 7131

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

Source

题意:

给定N个点,求出这些点一共可以构成多少个正方形。

思路:

先枚举2个点,之后算出另外两个点,判断是否符合

/*
由于我没有开个数组记录点的坐标,所以把cnt定为1005; 
*/ 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int M=20007;
struct node
{
	int x,y,next;
}a[20007]; 
int head[20007],cnt;
bool cmp(node a,node b)
{
	if(a.x==b.x) return a.y<b.y;
	return a.x<b.x;
}
void insert(int x)//进行哈希并且用链地址法解决地址冲突 
{
	int h=(a[x].x*a[x].x+a[x].y*a[x].y)%M;
	a[cnt].next=head[h];
	a[cnt].x=a[x].x;
	a[cnt].y=a[x].y;
	head[h]=cnt++;
}
int find(int x,int y)
{
	int h=(x*x+y*y)%M;
	for(int i=head[h];i!=-1;i=a[i].next)
	{
		if(a[i].x==x&&a[i].y==y)
		return i;
	}
	return -1;
}
int main()
{
	int i,j,n;
	while(scanf("%d",&n)&&n)
	{
		memset(head,-1,sizeof(head));
		memset(a,0,sizeof(a));
		cnt=1005;long long ans=0;
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&a[i].x,&a[i].y);
			insert(i);
		}
		sort(a,a+n,cmp);
		for(i=0;i<n;i++)
		{
			for(j=i+1;j<n;j++)
			{
				int x1=a[i].x-a[j].y+a[i].y;  
                int y1=a[i].y+a[j].x-a[i].x;
                if(find(x1,y1)==-1) continue;
                int x2=a[j].x-a[j].y+a[i].y;  
                int y2=a[j].y+a[j].x-a[i].x;  
                if(find(x2,y2)==-1) continue;
                ans++;
			}
		}
		printf("%d\n",ans/2);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值