Period
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 1956 Accepted Submission(s): 959
Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A
K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3 aaa 12 aabaabaabaab 0
Sample Output
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
Recommend
JGShining
code:
#include<iostream>
#include<cstring>
using namespace std;
int next[1000005];
char s[1000005];
int len;
void get_next()
{
int i=0,j=-1;
next[0]=-1;
len=strlen(s);
while(i<len)
{
if(j==-1||s[i]==s[j])
{
++i,++j;
next[i]=j;
}
else
j=next[j];
}
}
void kmp()
{
int i=1;
len=strlen(s);
while(i<len)
{
i++;
int t=i-next[i];
if(i%t==0&&i/t>1)
cout<<i<<" "<<i/t<<endl;
}
}
int main()
{
int n;
int T=0;
while(cin>>n)
{
if(n==0)
break;
cin>>s;
cout<<"Test case #"<<++T<<endl;
get_next();
kmp();
cout<<endl;
}
return 0;
}
字符编号从0开始,那么if(i%(i-next[i])==0),则i前面的
串为一个轮回串,其中轮回子串出现i/(i-next[i])次。
//http://acm.hdu.edu.cn/showproblem.php?pid=1358